Wowza Community

mediaReaderRandomAccessReaderClass problem with restful api


I am using WowzaStreamingEngine 4.4.1 at Ubuntu 14.04. I used restful api and created vod application (restful_vod) as in examples, it didn’t work didn’t stream vod files. That’s why, I compare application.xml files of default vod application and restful_vod application. There is a difference between MediaReader properties. Default vod application has no property at there but restful_vod has below:

  <!-- Properties defined here will override any properties defined in conf/MediaReaders.xml for any MediaReaders loaded by this applications -->

When I removed randomAccessReaderClass named property, it started to work. I realized mediaReaderRandomAccessReaderClass parameter manage its value. But I couldn’t find a way to prevent adding it while using restful api. I tried not setting mediaReaderRandomAccessReaderClass value and also setting mediaReaderRandomAccessReaderClass false, null and empty string.

Is there any way to prevent adding it or a default working value for this?



I just tried to recreate the issue you are reporting through the Swagger Documentation interface as outlined here:

I first used the GET command (3rd one down in the Swagger Docs interface) to pull in the configuration of the existing VOD application on my test instance then I took the output and used the POST command directly belwo that to create a new application.

I then reviewed my Application.xml for the new application and did not have this property in the MediaReader properties.

Can you try this same scenario and let me know the results?

If you are creating the application in using a different method can you post your command for the application creation here?


Jason Hatchett