Wowza Community

ModuleOnConnectAuthenticate.onConnect: java.lang.ArrayIndexOutOfBoundsException: 1


I’m struggling to get the OnConnectAuthenticate2 to work correctly.

When I add the channel name I get an error of “ModuleOnConnectAuthenticate.onConnect: java.lang.ArrayIndexOutOfBoundsException: 1”

If I only put the application name in it connects and works.

Ie This connects and streams fine ‘rtmp://’

This fails with the error above ‘rtmp://’

Without the channel it’s not possible to connect to the stream for playback.

I’ve tried several versions of the url to see if they work but none seem to. Ie without the port, with the server’s actual ip, a ‘/’ after the channel name.

The only time it works is with the channel name removed.

Any ideas would be helpful.

I assume I’m doing something wrong as I imagine there would be other threads if there was something broken.



The “channel” string should be considered as the application instance for your stream. What encoder are you using? Have you tried the following?


I tested with the above using an RTMP encoder and it worked correctly for me.