Wowza Community

New Axis camera with H.264

I’m trying to follow the instructions in (Using native RTP encoder…).

However, since the P3301 doesn’t have an sdp file anywhere that I can copy, what I’ve done is started up VLC in from a terminal window and then connected to the camera’s stream with VLC. This allows me to see the SDP info in the terminal window, copy it, and make an SDP file out of it.

I read that I had to modify the SDP file a bit, and it worked for me modified last week, but the same file from last week is not working this week :frowning:

Here’s what the SDP file looks like before modification:

o=- 983527116251980 983527116251980 IN IP4 CA.ME.RA.IP
s=Media Presentation
c=IN IP4
t=0 0
m=video 0 RTP/AVP 96
a=rtpmap:96 H264/90000
a=fmtp:96 packetization-mode=1; profile-level-id=420029; sprop-parameter-sets=Z0IAKeKQPBf8uAtwEBAaQeJEVA==,aM48gA==

I tried setting the port in the m line to the port that I use when accessing the camera’s RTSP stream, and it hasn’t worked yet.

Also, I figured I could test out my SDP file by opening it in VLC. That also doesn’t work. It says “No data received in 10s. Aborting.” So I figure it must be the SDP file.

However, I read somewhere that I can’t start a unicast by opening the SDP file alone, which seems to make sense, since if I can watch the stream by entering the stream URL: rtsp://cam-ip:554/axis-media/media.amp but I can’t watch the stream by opening the SDP.

Yeah, that seems to be the problem. I can get it to work if I enter:

rtmp://server-ip/rtplive as the server

rtsp://camera-ip:554/axis-media/media.amp as the stream

into the player swf in the live folder.

However, the framerate is terrible, around 3 fps, when the source is at 15 fps.

Actually, I just added patch 11, (I guess I hadn’t before), but I will try this one too.

Now the question is, how do I make this work without having to put the camera’s IP address in the HTML file that loads he player?

Patch 12 seems to work well too. Now to figure out how to hide the camera’s IP.

So I found the StreamNameAlias package here: and it takes care of my problem nicely.

However, I changed to running Wowza as a service, (so I don’t have to sit in front of my computer all day long), and now the super-low framerates are back. Are the latest patches used when running Wowza as a service?

Hi John

Did you change any settings in p3301 camera?

Did you find the sdp file on p3301 or Do you have to use vlc to generate the sdp?

where are you specifying the ip adress of wowza in p3301?

Thank You

I tried setting the stream name to

rtsp://camera-ip:554/axis-media/media.amp and it is working

how do you specify the user name and password to login to the camera. To test this , I enabled anonymous viewer login on the camera.

Is it the efficient way to stream?. Here we are pulling from the camera instead of camera pushing the stream to wowza.

I looked at the stream name alias package. Where do you specify the authentication information there?

I temporarlily enabled the anonymous viewers for viewing the camera.

Thank you


Hello Mat.

That is exciting. I’m going to probably get one ordered tomorrow.

Could you sniff (by wireshark) rtsp setup traffic between your camera and client? I try to emulate P3301 and VLC show my stream but another programs don’t recognize it.

Best Regards,


Today I played around with a Axis camera.

Could you capture and show RTSP messages log between your Axis camera and client?


Today I played around with a Axis camera.

I wanted to stream different resolutions and qualities without editing the settings in the administration panel. I found the following solution:

You can add these params to the ‘streamname’:








videobitratepriority=framerate (or quality)


Another hint:

In the Application.xml I set the StreamType to ‘rtp-live-lowlatency’ which gives me better results than ‘rtp-live’

Hey guys

I have tried to build a Recorder for the Axis camera, using the Module, ( I have modified it to start recording onPublish.

But its not working. I guess it’s because the stream hasn’t been pulled from the camera 100% yet.

Anyone have an Idea on how to initiate a recording from these cameras.

Use the rtp-live-record stream type.


But doesn’t this prevent me from setting specific file name etc…

I am trying to record the H264 stream from the camera with a specified name.

Any tips ?

Good Afternoon All,

We just got an Axis P3301 camera and we would like to stream from the camera to the Wowza Media Server, then allow multiple clients to connect to the Wowza Media Server stream instead of directly to the camera stream.

We’re currently using Wowza Media Server 1.6 and we’ve been trying to get the camera to stream to the Wowza server using a SDP file however so far have had no luck. We’ve used any SDP file examples ( with modifications ) that we’ve found in the forums.

We’ve searched through the related forums and we’ve been able to stream the camera to the Wowza server using the rtsp stream from rtsp://:554/axis-media/media.amp and using the server as the wowza server: http:///rtplive

The questions or issues we’ve encountered so far are:

  1. Can the Wowza Media Server accept the stream from an Axis P3301 camera and re-broadcast that stream to allow multiple clients to connect, with just the Wowza Media Server package or is some other third party software required to re-broadcast a stream ( Such as Wirecast )?

1a. If this is possible with Wowza alone what would be the process or steps for getting this up and running? ( Or are there forum posts that I’ve overlooked that could get me started? )

  1. If this scenario were up and running are there specific ports that a viewer needs to gather the rtmp stream from, or should a viewer be able to connect to the rtmp:///rtplive and load the stream?

  2. As far as the axis camera, are there any adjustments that can be made to the rtp settings to allow this scenario to work more smoothly.

  3. I tried creating a SDP file using VLC but had no luck. Is there some other method for SDP creation that has worked fairly well?

Any and all help would be greatly appreciated!


Thank you for your quick reply! I have actually tried these and this works just fine as far as streaming locally on the Wowza Server.

I guess my next question would be how would a client not on the Wowza Server connect to this stream. For example the stream is fed from rtmp:///rtplive

How does the client connect to the Wowza server to view this stream?

Also, say the client is connecting using a viewer on another server. So, webserver-a is hosting a viewer. How does that viewer on webserver-a point to the Wowza server properly to pick up that feed?

I hope that makes sense, if not please let me know.

Again, thank you very much for the quick response!


Thanks again! I’ll give that a go and post back after!




I’m having trouble getting more than 10fps out of an axis m1011 camera but it’s not fixed by increasing FlushInterval. As in the above post I’ve no problem with the frame rate when viewing the rtsp stream with VLC player. Does anyone have any other suggestions what could cause this?

Hi seems to be no change in the frame rate and I don’t see any packet loss statements in either of the log files.