Wowza Community

Player stops after a few seconds on iOS Safari 13

I am trying to stream to an iOS 13.3 Safari browser on an iPhone Xs Max.

I am also using the wowza player 1.1.18. I tested this on an iPad (6th Gen) running iOS 13.3 and an older iOS 7.1.2 iPhone 4 and they play fine

However, on the iPhone xs Max, the stream just freezes after a while. I am able to get out of full screen but can no longer play or pause. In the debug output/handlers, I do see that it triggers the pause and play events.

I have these custom settings set up as well:

cupertinoMinPlaylistChunkCount: 8

cupertinoOnChunkStartResetCounter: true

any help or guidance as to what I should do next?

For mobile streaming, it’s best to encode streams using a low bitrate, frame rate, and low encoding complexity. A total bitrate of between 64Kbps and 250Kbps is best.

Many mobile devices may not be able to handle a full 30 frames per second (fps). A frame rate between 15fps and 24fps may be best for mobile. It’s best to encode to a lower H.264 complexity. Most mobile devices only support H.264 Baseline profile.

Try these settings as well for chunk duration, cupertinoMaxChunkCount, cupertinoPlaylistChunkCount and let me know if that helps @Samuel Sanchez

Take a peek at this also for some additional troubleshooting:

I don’t think it’s an issue with the streams. This was tested via WIFI and was working well. The ipad worked well with iOS 12… then I upgraded the ipad to version 13.3 and the issue showed up.

I have a feeling the new version of iOS changed something?

That is exactly what we are looking at and you nailed it right on the head. Each device has so many different encoders and if one of them doesn’t like our SDK parameters for some reason, an issue arises. But, we are still looking into it and doing some testing @Samuel Sanchez

It turned out that the issue was that Safari was having a memory leak issue. We removed a feature from our site when we detected mobile/tablet Safari. However, with ios 13, Safari defaults the Browser Agent (for tablets) as ‘requrest desktop version’ It removes any mention of it being an iPad, thus triggering our memory leak causing issue.

Thank you very much for sharing that info!