Wowza Community

Recording with SSL enabled does not work


our wowza is configured to allow only secure connections (rtmps, https). We’ve tried HDFVR on a desktop and recording as well as playback with JWPlayer is working without issues. Now we are investigating the mobile streaming options and trying the GoCoder app. Unfortunately, we are not able to get it to connect to the Wowza server. If I enter as URL and 443 as port the application just hangs after pressing the red encoding button and I have to “kill” it. I’ve tried to enter https:// as URL and leave the port empty, but them I’m getting “Connection error”. To test the connection I’ve tried to call the wowza url in the browser. If I enter in my browser http://:443/ I’m getting:

killUnidentifiedSessions: Killing unidentified session: address:

in the Wowza log file and nothing in the client’s browser. If I enter https:// in my browser the Wowza Streaming engine… will be shown as expected. I

So, I think something is wrong with the URL being concatenated in this case?

Any help will be highly appreciated.


The current GoCoder app (nor the GoCoder SDK) does not support SSL connections to the server, We do plan on adding support for this in both the SDK and the App in an upcoming release.


Ok, thanks for clarifying it.

Hi, may i know when will this feature to support SSL for GoCoder SDK be make available?

Unfortunately, we do not have a timeframe yet at this time.