Wowza Community

RTSP + Android + Wowza.v3 = Keeps Cutting Out After 90 sec

Possibly an encoding issue?

What happens when you play the Wowza sample file?


Ok, then try some more troubleshooting to narrow down the problem:

  1. Play the Wowza VOD RTSP demo in your Android RTSP player. I use the free Doga player.


If it works then it would point to a problem with your Wowza installation. If not, possibly a network issue on your end.

  1. Try playing the simple flash demo in your Android browser by going to:

Just browse to there and watch the demo right on that page. It works well for me in Android 2.2.1.

Yes, that must have something to do with it. What are the results of playing the streams I mentioned above?

Also works for me on Android 2.2.1 over my DSL internet connection.


This problem is most likely related to UDP routing. Wowza Media Server will timeout an RTSP/RTP connection if we have not received any data from the player in the form of either RTCP packets or some sort of GET_OPTIONS request in 90 seconds. We properly signal that we have a 60 second timeout in the RTSP exchange. There is most likely an issue with UDP routing that is blocking the RTCP (UDP packets) from flowing from the player to the Wowza Server. These packets would be sufficient to keep the session alive. Since we are not getting these packets the session is dropped after the timeout. You can test to see if this is the case by editing [install-dir]/conf/[application]/Application.xml and changing the RTP/RTSPSessionTimeout to zero (value is in milliseconds, default is 90000). Changing this value to zero will turn off this mechanism. With this off the stream should continue to play.


Another test is to try our sample RTSP URL to see if the problem is isolated to your server setup. Try to playback this URL:


If it plays for more than 90 seconds then the problem is with the UDP routing/firewall that the Wowa Media Server is behind. There are suggestions in the RTSP Troubleshooting Guide if your server is behind NAT:

If this does not resolve the issue then try turning off all firewalls between your phone and Wowza Media Server. Again, the issue is most likely related to UDP routing/firewall.


Hello Steven,

No, I don’t think this will be a big problem. What this does is eliminate the timeout. If the clients have disconnected, the stream will disconnect.



You could try looking here,

This might get you started on the troubleshooting.

There are some settings that you can play around with relating to the timeout but 90000ms is high as it is.

Have any of the suggestions that Randall has made worked??



Ok, your firewall on Windows is open for all the necessary ports and protocols but if you are then behind a router they may be blocked from there.

Are you using a router?

Can you also describe “slightly better results”? from this,

“I have tried to change the RTSPBindAddress parameters with slightly better results”

Is the server in a data-centre or are you doing this from home?

Has the data centre got its own firewall?



You can get the independent consultants list if you’re looking for help.

Ask by email -