Wowza Community

SRT Ingest not working

I’m trying to switch our setup from unprotected UDP mpeg-ts towards a protected setup where our source transmits via SRT.

However I’m running into some issues:
-Wowza SRT does not seem to want to connect (caller mode) in any way or form to my SRT server, since we replicate the same setup over many machines this is a show stopper.
-Wowza SRT does not start receiving until I completely restart the Wowza process.

Any suggestions?

Hello and welcome to the community! Sorry you’re running into this issue.

Are you able to share any messages you’re seeing from the logs? When you say SRT server are you referring to an SRT encoder?

When you say protected do you mean HTTPS and you configured an SSL certificate?

I’d like to help you, but I need a bit more info. Whatever you can provide I appreciate it.

Do you have a port assigned just to the SRT? And not sharing with UDP?

SRT ingest does not support sharing ports like UDP in Wowza Streaming Engine

It’s an in-house developed application that is able to receive a RIST protected stream (our encoder output) and relay it in a number of other formats.
One of which is SRT.

When the SRT server is configured to listen and Wowza is configured to connect to that IP (following the instructions displayed on the right that state to insert the source IP) I see no outbound traffic from the Wowza machine trying to connect to the SRT server, as measured via tcpdump.

When setting up the reverse, Wowza configured to listen Wowza does not pick up the stream until I restart the Wowza server or reset the stream via the web interface and connect it again with the option to do so.

There are no shared ports.

Does Wowza have the intention to support RIST? This would be a much preferred solution for us, since RIST supports multicast.

No plans at this time for RIST support, but I would submit a support ticket to see if we can figure out why that SRT ingest is not working. We’d like to take a look at that RIST to SRT transmuxing and test it out. We might have a syntax issue there we could work out.