Wowza Community

SSL certificate gets revokated on Firefox


from no reason, firefox does not want to run our wowza server because he says our certificate is revocated… chrome works great… and it worked on firefox for years…

could someone help me and tell me where it can come from ? why all browsers work properly ? specially it worked for years and now for any reason suddenly firefox does not recognize the certificate, it is a wowza problem because wowza handles the certificate so we are clueless here

thanks !

You’ll have to convert the certificate and import it into a Java Key Store. Google for “godaddy certificate to jks” and you’ll find lots of guides and helpful links. You may have to try a few; but eventually you should have the JKS, which you can add to the Wowza folder and reference in the VHost.xml

Thanks Karel ! We installed the certificate and it works great in Chrome.

But in Firefox it’s revocated. How is that possible ?

It used to work also on Firefox.

is there something you see that could make it not work on FF ?

${com.wowza.wms.context.VHostConfigHome}/conf/tv-all.jks xxx