Wowza Community

"Stream Not Found" with H.264/AAC .mov file

Hey. I posted this question over at the JW Player site as well… I’m having trouble getting a H.264/AAC .mov file to stream using Wowza and the JW Player 4.2. I’m hoping someone can tell me where I’m going wrong. Strange part is, if I manually change the .mov extension to .m4v, it streams fine, but I need the .mov extension for sanity sake. I encoded the video with Apple Compressor as H.264/AAC.

Here’s the embed code I’ve tried, directly out of JW Player readme.html:

<div id="container">
<a href="">Get the Flash Player</a> to see this player.
<script type="text/javascript" src="swfobject.js"></script>
<script type="text/javascript">
var s1 = new SWFObject("player.swf","ply","620","485","9","#FFFFFF");

Again, the video will stream perfectly if I manually change the video file extension to .m4v, so I’m totally stumped…


Any suggestions would be greatly appreciated!

Here is a link to the the forum where jeroen discusses, but gives no definitive answer

Does this mean I can’t use the .mov extension?

JW Player keeps changing in this regard. See what Jeroen has to say. It is clearly a player issue. I am sure if you try our SimpleVideoStreaming example player that it works as expected (as far as the extension goes).


Let me look at this and I will try to mimic what FMS is doing. The whole this is pretty strange.


I looked at this closely and I think Jeroen is wrong about the FMS behavior. I will contact him to have him take a look at it.


Also, it could be that the file does not contain H.264 video. A .mov file (Quicktime container) can contain many different types of video/audio codecs. Many of which cannot be played by Flash. Use a program like GSpot to inspect the file to see the codec of the video (


Have you tried testing with the Wowza player, /examples/SimpleVideoStreaming/client/simplevideostreaming.html


In the short term here is a zip file containing version 4.2.90 of the JW player modified to work with Wowza JW Player that works with Wowza for any that may need it.

Regards - Jimb

Glad to help when I can. These two products are the best and both have great support.

This simple fix is really the result of the advice I got from Charlie about a month ago when I first installed Wowza. It was his tip after I shared the accesslog errors that lead to the solution.

Regards - Jimb

I note that as a result of Charlie’s thoughtful suggestion the folks that publish the JW Player have opened a ticket on this issue so a fix to their player is pending.


Here is what Jeroen says about the issue:


Second notice, this was already there. Let me explain how the player works:

  1. first, the player needs either a valid extension (mp4 / mov / flv / m4v / mp3 / etc) or the flashvar “type=video” to recognize a video has to be played and not a playlist.

  2. Second, the player will detect a “streamer” flashvar. If there is one and it starts with “rtmp”, the RTMPModel is selected for playback.

  3. The RTMPModel connects to the “streamer” application.

  4. The RTMPModel plays the video. It does a small rewrite on the file, in order to set the correct rtmp file syntax:

a) “video.flv” will remain “video.flv”

b) “video” will be renamed to “video.flv”

c) “video.mp4” or “” will be renamed to “mp4:video”

d) “video.mp3” or “video” will be renamed to “mp3:video”

So this last part is the trick, and this is how Flash Media Server wants it. It could be that Wowza doesn’t need the ‘mp4:’ prefix and therefore all .mov files do not work (and the .m4v files do, since they are not renamed)…

Seems a shame. I love his player… Where can I get/download the player you recommend?

JimBaker, OMG you are amazing! I saw your post on JW site as well! Thanks so much for your help. You saved my sanity… I owe you one!

That’s great news! I look forward to the next version of the player. Thanks again for your help!

I guess I may not have understand what, if any, the fix is. My code is this.

The stream starts and plays sound but no video. If I convert to FLV it plays fine. Is this a problem with the file or the way wowza or the player sees it? The file plays fine from my desktop using quicktime.

Any help would be great to work out this last bug to stream mov files along with flv.