Wowza Community

Streaming to HTML5 from wowza

Great. Thanks for the update


You can’t use “localhost”, it has to be the IP or domain name of the server running Wowza.


It is same at present, limited to iOS and Safari on Mac


Any updates for this? (wowza server 2/3)

The only way to use html5 video tag for streaming is to use iOS devices or safari on mac? It’s not possible on windows at all?

going to test this on my mbp

Thanks Richard. So,this will enable the folks using firefox4,google chrome and IE9 to view live/recorded streams without any Flash plugin right?

Then,how do I stream to those browsers ?

Youtube seems to have this html5 working on their site.I was able to see videos without the flash plugin. How do I enable similar functionality using wowza?

Does wowza plan to support html5 for browsers in the future?

If so,is there a beta version available which I can try?


Thank you Charlie. That really gives me some hopes. But, I’m eagerly waiting for that to get released :slight_smile:


Are you using the StreamNameAlias module? StreamNameAlias: Simple & powerful stream name alias module

The alias names are set in alias txt files not in Application.xml.

That is correct. There’s some discussion here: Live streaming and HTML5

And here: HTML5 Support for video playback

We use the following code:

  <title>Cupertino Streaming</title>
<video controls src="http://[wowza-address]:1935/live/mStream/playlist.m3u8">

The link to stream on IOs is the following:


We added an alias (and uncommented the alias tags in the Application.xml)


But we get the error:

Stream alias access denied mStream.

at live.html, and

The video could not be loaded, either because the server or network failed or because the format is not supported.

, respectively

at IOs devices.

We use Flash media encoder.

How can we fix this problem?

Thanks in advance

Thanks for the reply.

Yes, the alias


is set in the alias.streamer.txt, together with the other working aliases.

In the Application.xml are only the alias module and its properties.

I also tryed the following aliases (but nothing worked):


At first, thanks for the reply.

When I use the code this way:

  <title>Cupertino Streaming</title>

<video controls src="http://[wowza-address]:1935/live/[B]myStream.sdp[/B]/playlist.m3u8">


I get the following error:


The video playback was aborted due to a corruption problem or because the video used features your browser did not support

Thanks for the quick reply.

I recently have reinstalled the encoder because of some problems with the aac

license and I did not check that the encoder was not set to h.264 Format.

Thanks again.

Does the OS have to be Mac OSX? Can I stream to safari on a windows machine?

Also does this work for VOD?

First remove the StreamNameAlias package.

In your encoder, make sure you have select Format h.264, then click little wrench icon next to format and select Baseline 3 profile. If MP3 audio, make it Stereo 44100Hz.

Make the Stream name “myStream.sdp”

Configure an a live application following this tutorial, and make sure you follow the Cupertino configuration steps:

Then test in Flash with Wowza example LiveVideoStreaming:

Server: rtmp://[wowza-address]:1935/live

Stream: myStream.sdp

Then test in iOS device.


I tried the code

<video controls="controls">			
<source src="http://localhost:1935/live/myStream/playlist.m3u8"/>

It works fine for the test in Flash with Wowza example LiveVideoStreaming, but for some reason I can’t play it through an iOS device. It just shows the player with a crossed out play button.

I’ve followed all the instructions with regards to the fmle encoder and the wowza streaming setup. Is there something I’ve missed?

Thanks a bunch! It works perfectly now.

Have any version available for this today?

It’s possible streaming to others desktop browsers now, or the only way to use html5 audio/video tag for streaming is to use iOS devices or safari on mac?