Wowza Community

StreamLock Port 443 HTTPS Conflict Issue


I have installed a StreamLock keystore in the wowza installation folder and configured the setting in the EngineManager.

When I tried to test out the connection and streaming by
I ran into the error because apparently our web server management program Plesk handles all SSL certificates and the above command to play the sample file at port 443 led to the Plesk directory instead of the Wowza installation directory in looking for the sample.mp4.

Is there a way to resolve this issue from the Wowza configuration ?

In other words, is there a way to configure the Wowza settings and generate the StreamLock in such a way to allow the Plesk to the streaming files under the Wowza installation directory? Where is the setting in the Wowza server that tells the StreamLock to call up the video file from its /contents folder?

Our hosting company tech support suggested that I convert the domain SSL certificate into the Wowza StreamLock certificate format [ssl-certificate-domain-name],jks and put the Wowza installation forlder under the Plesk folder so that Plesk can search for the video files. But, I’m not sure whether this will work or not.

If so, how can I install the Wowza under the directory other than its default directory under C:program files x86?

Thanks very much for your help.

My advise would be to get rid of Plesk on that server, or install Wowza on a separate server. I’ve tried myself to make Wowza works with control panels like Plesk, CPanel, etc. and it’s frustrating. It doesn’t help to move the content folder to a place that is accessible by Plesk, because Wowza reads the files and streams the content over HLS, RTMP, or whatever Streaming protocol you chose.

The one thing you can try, is to edit the VHost (either via the Engine Manager panel, or directly in VHost.xml) and set the SSL port to something different than 443; e.g. 4430. Then restart Wowza and you should be able to access your streams via https://[ssl-cert-domain-name]:4430/vod/… That is: if Plesk allows processes to use ports outside its control.