Wowza Community

Two stream in the same application

Good morning everyone,

my need is to publish two different stream (with different name) to the same application on a Wowza media server 3.0.5 running on amazon ec2. Do you think that is possible?

This is what I’ve done:

  • I’ve created a folder in applications called “cupertino”

  • I’ve created the application.xml file for cupertino streaming to iOS devices

  • I’ve stated send fro wirecast two different stream called and both via rtmp to mywowzaserver/cupertino/definst

  • I’ve started receiving both stream in the cupertino application folder from the wowza stream manager

Now the problem…when I go to the test addresses of the streams I always see only one of this streams (always the first one I’ve started). I don’t have any problem in publishing one stream, it seems wowza find something wrong when I try to publish two streams and so only one is visible.

Anyone could help?

Thanks in advance,

Marco :slight_smile:

Hi Marco,

What is the contents of both of your .stream files?

Start Wowza from the command line (startup.bat). Any error messages?

This is the tutorial to follow if you are using Wirecast:


It might be a problem with the uplink bandwidth at the encoder. If you make both streams less than half bitrate (video+audio), does it work then? We have this tool for testing bandwidth between a client (your encoder) and Wowza:

If the the half-bitrate test fails, do this:

  1. Stop Wowza, delete or rename the current access log, then restart Wowza.

  2. Start the encoder, publish one stream, then publish the 2nd stream

  3. Open LiveVideoStreaming Wowza example player, then play the 1st stream.

  4. Open a 2nd LiveVideoStreaming player in another browser tab, then try to play the 2nd stream.

  5. Zip up conf folder and the current access log and send it to Include a link to this thread.


Hi Marco,

See the difference between (RTMP Based Encoder) and (RTSP/RTP Based Encoder) in the Tutorials section. You don’t need to “pull” streams using .stream files and the Stream Manager, if your encoder is “pushing” RTMP streams to your live app. The stream names will be made automatically available for playback from Wowza.

Yes, 1935 is the default port for RTMP. So, you can just omit it.

When you have a streamname like this: rtmp://mywowzaserver:1935/cupertino/definst, the last part will be the application name. So you were trying to publish two streams named “definst” which is confusing. All you need to do is publish two streams like this:



Playback the same:

Server: rtmp://mywowzaserver/cupertino/

Stream: myStream1

You should be using this tutorial:

Randall, i can’t access Wowza via command line at the moment, but i can tell you that i need to delete the .stream file in the content folder to make my stream work properly.

Let me explain you:

I was following the guide document and i made a file containing , but when i try to publish my stream via wirecast sending to this rtmp mywowzaserver:10000/cupertino/definst my encoder was not able to reach the server and gave me an error. By deleting the file and by sending the signal fron the encoder to mywowzaserver/cupertino/definst (without the port specification) everythings works fine. Always with only one stream, when I tried with two stream the problem was the one that i explained before, both were sent without error but only one live was visible.

It seem my encoder (wirecast) have some problems to publish via port 10000, when i publish without specifiction it works fine and also when i publish via 1935)mywowzaserver:1935/cupertino/definst) port works correctly.

Any known issue about this? What is your advice? Re-upload the two .stream files and try to use some other ports?

Thanks in advance and sorry for my bad english! :slight_smile:


Thanks Randall and Richard,

maybe at the start i was a little bit confused between rtmp/rtsp based encoder.

Now i follow the step of the guide to set-up a stream for ios devices using wirecast, everythings works fine since I added another stream. Here’s the problem still remains, I always can see only one stream if i try to publish more than one to wowza.

-I’ve created a folder [install-dir]/applications/ios

-I’ve created a folder with the same name (ios) in [install-dir]/conf

-I’ve copied the pre-configure version for live streaming of Application.xml into this folder

-I publish the two stream from wirecast with this information:


Server URL: rtmp://[my-wowza-address]/ios

Stream Name: iphone


Server URL: rtmp://[my-wowza-address]/ios

Stream Name: ipad

I can see each stream if i publish them severally, but when i publish both at the same time (wich is my need) I can see only one stream, the other doesn’t play.

Do you think I need to configure something specific to publish multiple stream on wowza? any ideas?

we’re stuck into this and we’re not able to find a solution.

Thank you all very much,


Thanks Richard,

I’ve sent an e-mail to support containing the logs and conf folder.

Reading the log I find an error “Hit license limit for publishing streams.” in reference to the second stream (the one that is not playable), could that be the problem?

Let’s see , thanks a lot.


I solved the problem!

I post the solution for other users.

There wa a problem with license update, I was using a developement license that contains limitations.

Once I’ve updated the Server.license file with my monthly License key in the “conf” folder everything works fine.

Thank you all,