Wowza Community

Unable to connect to Primary Server

I have created a test stream.

I am unable to connect to the Primary Server from my encoder.

I keep getting the error message:

Failure to connect to Primary Server. Please verify that your Server URL and application name are valid.

Please suggest what to do.


Hi Mahesh,

can you please make sure your stream in Wowza Cloud is started prior to connecting with your source encoder.

What encoder are you using?

If you did this already can you please send a ticket to

Thanks Philipp

Ok. I started the stream from Dashboard and then tried to connect.

It showed the same error when I used the ***** in the server URL.

But got connected when I replaced it with the Server IP that was showing alongside the server URL.

Am I still missing anything?


How much time you think it should take for DNS to get refreshed?

I still can’t connect using the hostname. Its not an issue for me as I can still connect using the IP address.

But you might need to check at your end if its a bug.

While I can stream the video, and I can see it on the Overview tab that the stream is being received. I can’t view the video on the player itself.

I tried my own player and it didn’t show the video when I used the hostname but showed when I used the IP address.

This is something I think your team should really look into.

It worked after sometime.

My concern is the time DNS server takes to get refreshed.

If in the player the hostname is being used and DNS doesn’t get refreshed then the videos might not play at all.

Hi Mac,

I am from India and I am using Flash Media Encoder.

Usual workflow is as follows:

  1. Start the stream from Dashboard.

  2. Connect to the primary server from FME. [this is where i faced issue initially as I didn’t start the stream from dashboard]

  3. Start encoder.

After this I tried to watch the streams on the webpage hosted by wowza cloud and faced some of the issues.


Could you please provide more information on your workflow please:

What encoder are you using?

What is your geographic location?




Please submit a support request and provide us more detail. Specifically, how long is it taking the DNS to refresh for you? Also, can you provide more detail about “faced some of the issues” during playback?

We thank you for bringing this to our attention and want to spend additional time in working toward a solution for you.



Hi Mahesh123,

The DNS name may not yet have refreshed for your network, which is why the IP address worked but not the hostname. You can try reconnecting using the hostname (* again at a later time. You can also test if you can reach the server via the hostname by running a ping command on the hostname.


Hi Mahesh,

Please send a support request via your Wowza Portal so that we can further investigate this issue. Please include a link to this thread for reference, and the email address you used to access your Cloud account.