Wowza Community

Video encoder is stuck, recreating.

Engineers say not a Java issue, we had some other reports of 4.8.0 not working on windows with the kepler cards. Sorry for this and yes I let the engineer assigned to your ticket know you are ready to continue the conversation.


I have the same issue with video encoding stuck using Tesla cards. Strange thing is that on some older Windows Servers it’s all running fine. It’s a problem with latest installations. I tried to compare the older and newer servers but cannot find any differences. Also swapped cards between servers but nothing seems to help. Really strange. Anybody find something that can solve this issue?

Thanks, Joost

Can you confirm what version of Engine you’re using @Joost_Sanders? We’ve had a few new releases since then with updates.


We use the latest release.

We just released it yesterday- version and it has an update that may solve your issue:


With the upgrade to NVIDIA NVENC SDK 9, Wowza Streaming Engine supports higher quality transcoding workflows when using NVIDIA Turing or newer architecture. The Wowza Streaming Engine Transcoder supports NVIDIA 440.xx drivers, but does not yet support NVIDIA 450.xx drivers.

Not sure if that may be worth a try or not for you @Joost_Sanders. If you do though, please be aware of the potential breaking changes in the You can read them here:

Hi!. Experiencing the same issue.
Wowza on Windows 10
NVidia drivers 461.40
2x GTX970 (non SLI)
When try to transcode with NVENC, the first 3 streams work Ok, but the 4th one start to raise errors:
WARN server comment -[videoEncoderGetEncodedFrames][720p]: Video encoder is stuck, recreating.
EncOpenEncodeSessionEx(&encodeSessionExParams, &hEncoder) returned error 10 at nvenc9\NvEncoder\NvEncoder.cpp:52

Looked through the comment section, will try to downgrade video drivers to 440.xx, will report results when they will be.

Downgraded to NVidia Game Ready 445.87.
The same issue.
3 transcoding streams work ok, the 4th one -
Video encoder is stuck, recreating.
NvEncoder::NvEncoder : m_nvenc.nvEncOpenEncodeSessionEx(&encodeSessionExParams, &hEncoder) returned error 10 at nvenc9\NvEncoder\NvEncoder.cpp:52

shared library: D:/Wowza Streaming Engine

That’s a problem. We planned to use NVENC for at least 16 streams being transcoded simultaneously.

UPD. Study of a problem indicates that it is possible that we hit limitation of 3 concurrent sessions provided by GTX 970.

Hi Rose,

Coming back on this issue. The K20 en K40 only seem to be working well with:

  • Wowza version 4.7.6
  • Graphics driver 377.35
  • SDK 8

We recently tried a NVidia T4 with all the latest versions:

  • Wowza 4.8.14+9 Build 20210719152831
  • Graphics driver 471.41
  • SDK 11.4

Encoding is working so not stuck anymore, but now decoding does not work! Wowza service just stops like it’s missing something.

Any idea?

Thanks, Joost

Oh no! So what I know about 4.8.14 is that because we have switched over to Beamr,

  1. You must make these changes for decoding:

  1. If you have any advanced parameters see this doc HERE.

  1. You MUST have support for CUDA 11 and make the changes required:

  1. If you are using Windows @Joost_Sanders, then you need to see this in the release notes for 4.8.14

Did you see all the release notes for 4.8.14? There is quite a bit of info on the breaking changes:

Hi Rose,

But Beamr does not use the Nvidia card or am I missing something?

Ok I can clear this up and sorry for all the confusing details @Joost_Sanders

The K20/K40 GPUs were deprecated in the newest releases (kepler GPUs),

The T4 card should work, but you need to use NVENC for encode, NVCUVID for decode, and CUDA for scaling in the transcoder template.

if you have CUDA set for decoding, it won’t work.

Does that help?

Feel free to send a support ticket if you’d like an engineer to work directly on your needs for this. I hope that cleared it up a bit though.

@Rose_Power-Wowza_Com, hm, ok that does not really help. As mentioned earlier, the windows service stops as soon as Wowza starts decoding with NVCUVID set. If we select default or Beamr for decoding the process does not crash and the T4 starts encoding. However, we want the T4 to do decoding as well. It looks like the Wowza install missing a decoder codec for Nvidia or something?

Ok are you on a trial license or developer license by any chance? Can you please send a support ticket? The engineer who tested the transcoder yesterday didn’t have the issues you are and tech support is curious to look and see what we may be missing here since it’s clearly affecting you.

The information I provided to you was given to me from tech support after they tested it, so we’re really eager to see what’s going on in your configuration. Obviously, not a great situation that it’s crashing for you.

Can you please send a ticket? In case there is a bug we’re not aware of? They need to track that in the ticket. Sorry you are experiencing this frustration.

I have same as Joost_Sanders mentioned above , please let me know if this problem solved