Wowza Community

WebRTC publish/play is not enabled for application: videochat

Hello

i’m trying to setup the webrtc features, but so far no success. i can access my server infos with streamlock url, but when trying to play a stream (from rtmp transcoded in vp8),i have the following error:

WebRTC play is not enabled for application: videochat

same message if trying to publish (WebRTC publish is not enabled for application: videochat)

also,i notice this line in the logs when restarting the server after doing the webrtc conf: WebRTCVHostListener.onVHostInit: Not needed anymore, can be removed from Server.xml

any help appreciated

Hello,

This is probably a setup issue within the webrtc Application xml. I would recommend going over the WebRTC readme again and if that does not help, please open a support case and send the below folders for further review by Wowza Support.

[install-dir]/conf

[install-dir]/logs (only latest logs showing connection attempts)

[install-dir]/htdocs

If you are not sure how to get this information please see the following tutorial.

https://www.wowza.com/docs/how-to-create-a-compressed-zip-file-in-windows-os-x-and-linux

If files are too big for email transport, please send a link to the files.

For your “webrtc conf: WebRTCVHostListener.onVHostInit: Not needed anymore, can be removed from Server.xml” warning; the WebRTC VHost Listener in the Server.xml is not needed for Wowza Streaming Engine 4.5.0 or later. This can be commented out or removed.

Regards,

JasonT