Wowza Community

WMS Plugin Collections

Are the plugin collections compatible with version 4.0?

I’m interested in loopUntilLive but I could not get it to work on version 4.0 like I did on version 3.63.


What didn’t work? which steps did you do? what did the error logs say? a bit more info would be nice.


I am a monthly subscriber who uses Amazon EC2 along with Wowza and JWPlayer 6 to stream live video. I use FMLE to encode the video.

In WMS 3.6.3, the loopUntilLive Module would play a video until the live stream started. I can no longer get it to work in version 4.0.

Here is what I did to install it:

Download Wowza Streaming Engine onto EC2 instance

Port 8086 - 8088 must be open for Wowza Streaming Engine 4

Open Terminal on Mac

Connect to EC2 instance

Type: sudo ssh -v -i /path/to/keypair/example.pem ec2-user@public-DNS

Update the EC2 instance

Type: sudo yum update

Download Wowza Streaming Engine to folder /home/ec2-user

Type: wget

To install

Type: sudo chmod +x WowzaStreamingEngine-4.0.0.rpm.bin

sudo ./WowzaStreamingEngine-4.0.0.rpm.bin

Accept user aggrement.

Enter username.

Enter password.

Enter license key. ( I got my new license key by emailing

Test live stream before we go further: success

To install wms-plugin-collection.jar which is located inside and unzip.

Locate the wms-plugin-collection.jar file inside the lib folder and upload it to EC2


ftp the wms-plugin-collection.jar to /home/ec2-user

mv file to WowzaStreamingEngine-4.0.0/lib folder

change file permissions and ownership to root

Type: sudo mv -f /home/ec2-user/wms-plugin-collection.jar /usr/local/WowzaStreamingEngine-4.0.0/lib

sudo chown root:root /usr/local/WowzaStreamingEngine-4.0.0/lib/wms-plugin-collection.jar

Test live stream before we go further: success



Test live stream : success

Test loopUntilLive : failure

Error log was blank but the access log show this:

2014-02-14 20:51:23 EST comment server INFO 200 - ModuleStreamPublisher.onAppStart: [live/definst]: XML Parse failed - - - 3.672 - - -

I ran the Application file through w3schools online xml validator and it found no errors.

Thanks for following up on this.


Hello Roger,

I just wanted to say thanks to your team for addressing the WMS Plugin Collection. I really like the way that the Stream Publisher and the Loop Until Live modules work. They seem to be very stable since the recent update.

The service and support makes Wowza Streaming Engine one of the best products that I have seen in recent years.




2014-02-14 20:51:23 EST comment server INFO 200 - ModuleStreamPublisher.onAppStart: [live/definst]: XML Parse failed - - - 3.672 - - -

You are getting this message because there is an error in your streamschedule.smil file. I will get this message elevated to an error level message and also make it more descriptive.

The smil file that is used by the Stream Scheduler cannot be configured using the smil file option in Wowza Streaming Engine Manager and must be configured manually as it was previously.



Thankyou for the complements.

Just to let you know, if you haven’t discovered it already, We have just released a new version of the Collection. There are a few new additions and still retains most of the old bits that haven’t been moved into the core product.

All of the articles are now in one place so it should be easier to find what you are looking for.

Check out Addon: Collection in the list of articles.


i havent used or tried this one before. i will give it a try to see if i get the same results. keep you posted


can you tell me which settings you have used in these 2 topics. there are quite some optional variables. i dont know which one you have used.



if i use the basics i can’t get it work

turned live stream OFF in fmle

try to get the stream in vlc - no connection


2014-02-16 12:49:46 CET comment server INFO 200 - MPEGDashWriterHandler.createChunkM4S[live/definst/Stream1]: Add chunk: id:4 type:m4s_video v/k:270/3 duration:11250 - - - 447.86 - - - - – - - - - - - - - - - - - - - - - – -

2014-02-16 12:49:48 CET comment server INFO 200 - LiveStreamPacketizerSmoothStreaming.addFragment[live/definst/Stream1]: Add chunk: type:video id:10 count:90 duration:3750 - - - 449.969 - - - -

so it makes the playlist

but it doesnt start the filler video when i connect to my live stream

if i try to get the filler stream straight from the server it works


but what i see in version 4.0 is you might have to set bitrates, width,height,etc. im not sure if this is needed or not.

but normally my stream would be (in this case in vlc): rtsp://

so i don’t know yet how i can get it work

i think the complete setup has changed for version 4. i have to dig deeper into this

if i look to the smil files that you can create with wowza 4

<smil title="stream">
                        <video height="200" src="sample.mp4" systemLanguage="eng" width="300">
                                <param name="videoBitrate" value="10000" valuetype="data"></param>
                                <param name="audioBitrate" value="30000" valuetype="data"></param>

and the example for wowza 3.x there is quite a difference. when i add the smil in wowza streamingmanager in 4.0 i cant get it to work at all.

when i use the one from the tutorial i can get it a bit to work.

so Wowza admins can you give us an update on this how to make this work?

        <stream name="Stream1"></stream>
        <stream name="Stream2"></stream>
        <playlist name="pl1" playOnStream="Stream1" repeat="true" scheduled="2013-09-25 16:00:00">
            <video src="mp4:sample.mp4" start="5" length="5"/>
            <video src="mp4:sample.mp4" start="50" length="5"/>
            <video src="mp4:sample.mp4" start="150" length="5"/>
        <playlist name="pl2" playOnStream="Stream1" repeat="true" scheduled="2013-09-25 16:30:00">
            <video src="mp4:sample.mp4" start="0" length="-1"/>
        <playlist name="pl3" playOnStream="Stream2" repeat="true" scheduled="2013-09-25 16:00:00">
            <video src="mp4:sample.mp4" start="30" length="5"/>