Wowza Community

Wowza - Plugin activation - Stream target list gets empty... solution ?


i am developing a Plugin for Streaming for our wowza-servers and its working as intended, but has 1 little problem.

When i use the my plugin on our main wowza-server all the configurated stream-targets disappear.

I am trying to figure out the main reason for the problem, but right now i was able to identify some more detail about the problem, but was not able to solve it.

Maybe someone here has an idea.

== Problem is:

  • My module extends HttpProvider & is compiled as a jar-file, which i put into the /lib-folder.

  • after i activate the class with full qualified package name & class-name => all stream targets disappear after server restart

  • btw. the module is running without any problem on another server, where no stream targets are setup

== To keep the problem simple:

I searched for an existing officially Plugin using HttpProvider including the official source.

So i found Official Blacklist-Plugin using the precompiled Jar (inside zip) everything works fine.

But when i just recreate the project (using Offficial Git-Source) and compiling it all on my own and putting this compiled jar-file into the /lib-folder the stream targets disappear.

VHost.xml-config is as mentioned here.

== In Detail:

Wowza-Server: Wowza Streaming Engine 4 Monthly Edition build19165

Wowza-Server-Config: has Stream-Targets setup

No Problem: using precompiled Blacklist-Plugin-Jar-File

Problem: compiling Blacklist-Plugin on my own & using this Jar-File all stream targets disappear in the wowza-engine-manager

The server was running wowza 4.30 before with plugins & configurations.

We updated it to the newest version, but the problem is not yet solved (Stream-Target-List is empty, after server restart).

When i look inside the /logs/wowzastreamingengine_error.log:

#Version: 1.0
#Start-Date: 2016-10-19 10:10:05 CEST
#Software: Wowza Streaming Engine build19165
#Date: 2016-10-19
#Fields: x-severity     x-category      x-event date    time    c-client-id     c-ip    c-port  cs-bytes        sc-bytes        x-duration      x-sname x-stream-id     x-spos  sc-stream-bytes cs-stream-bytes x-file-size     x-file-length   x-ctx   x-comment
ERROR   server  comment 2016-10-19      10:10:15        -       -       -       -       -       9.97    -       -       -       -       -       -       -       -
PushPublisherManager.getPushPublisherModule[wd]: Error accessing ModulePushPublish null: java.lang.NullPointerException
|at com.wowza.wms.pushpublish.manager.PushPublishManager.a(
|at com.wowza.wms.pushpublish.manager.PushPublishManager.a(
|at com.wowza.wms.pushpublish.manager.PushPublishManager.getEntries(
|at Source)
|at Source)
ERROR   server  comment 2016-10-19      10:10:33        -       -       -       -       -       28.542  -       -       -       -       -       -       -       -       
Problem shutting down : java.lang.NullPointerException
|at com.wowza.wms.vhost.VHost.shutdown(
|at com.wowza.wms.vhost.VHostSingleton.shutdown(
|at com.wowza.wms.server.Server.stopVHost(
|at com.wowza.wms.server.Server.stopVHosts(
|at com.wowza.wms.server.Server.stopServer(

First of all i thaught about special server settings, but this shouldn´t be the problem, because the precompiled official-blacklist-plugin-jarfile is working.

The only difference i could think of can be the compilation settings.

The official plugin is compiled with an older version. My compilation (of the official git-hub-src) is using wowza (like the version on our server) using eclipse with wowza-ide-2.

Right now, i don´t have any idea.

Any ideas are appreciated.

Thank you.


You should be using Wowza IDE 4 plugin, as this is compatible with the Wowza version that you have. Please use this plugin and see if you continue to have issues.


After some more testing, i finally found the solution.

In Eclipse-IDE (with Wowza-IDE-2-Plugin) on Project-Settings > Java Compiler:

  • Enable Project specific settings: yes

  • Compiler compliance Level: 1.7 (was previously 1.8)

So compiling the wowza-plugin.jar with Java 1.8, caused the error-log-entry above, so the “Stream Targets”-list got empty.

solved - thread can be closed

EDIT: ops, i just saw… i posted it into the wrong sub-forum. Please move to Java Subforum.