Wowza Community

Wowza Streaming Engine Manager not displaying the server IP

I have a Wowza Streaming Engine running on an Amazon EC2 instance.

I am using the Engine Manager tool to connect to the server and I can administer the server, but on the homepage the Connection Settings panel on the right displays null for the Server Ip and 0 for the port.

Thus every time I am using the provided players have to type in the address and the port manually.

I could not find the place to configure this information yet. Can you point me in the right direction?



There’s a property you can change directly in [install-dir]/conf/VHost.xml

Where it is currently set to the default ip and port that yours doesn’t seem to pickup.


You’ll need to restart the services after that change.

See if that helps.



The Wowza pre-built AMI show the external IP.

In you’re case you’d have to explicitly specify the Elastic IP in the above IpAddress setting,

as it doesn’t currently get picked up automatically.


I updated my VHost.xml configuration file to include the tag.

I updated the server from 3.6 and kept the previous VHost file.

Now I see the IP address, but there is another issue.

We are using wowza on an Amazon EC2 instance. The ip that is detected is the IP of the system inside the Amazon cloud, not the associated Elastic IP address.

Any suggestions?