Wowza Community

WowzaStreamingEngine not starting with systemd

I have recently installed WowzaStreamingEngine & Manager 4.1.2. Things appear to be working well. However, in testing if I reboot the machine at all when it comes back up the Wowza Services are not running. This is a Centos 7 System. Fresh install on a staging machine. If I manually start/restart the service with systemctl everything works as expected. Just not sure why it is not starting up like it should. Not sure if anyone else is having this issue.


This is usually caused when the server starts and Wowza tries to start before the NIC has started. As a result Wowza fails authentication as you don’t have internet access and this means that Wowza doesn’t start.

When starting Wowza manually the server does have internet access and so the authentication is passed and Wowza starts as expected.

To resolve this problem you can configure Wowza to have a delayed start so that your NIC has a chance to start first to avoid the failing authentication with the licensing server. You will need to edit the /lib/systemd/system/ then the [unit] section contains a “After=” option which you can then put or something similar from your system so that Wowza will wait to be started when the network is already active.




I thought it could be something to this effect similar to CIFS needing delayed. However, I have no systemd-wowza anything in my /lib/systemd folder.

Not sure what is going on but nothing I have tried is working. I do not see a systemd.WowzaStreamingEngine service listed anywhere. I do have a S80WowzaStreamingEngine in my /etc/rc.d/rc3.d however. It is set to start late but I am still not getting the service to start after a reboot. I can work around this but I need them to start after a restart for our less versed users who are not as familiar with terminals etc.

Has anyone found a resolution for this issue? I’m currently experiencing the same issue under the same circumstances. Thanks!


I exactly have the same problem.

I have centos 7 installed and WowzaStreamingEngine. At the end of the installation, I answered “yes” to add the service at the startup.

If I do chkconfig --list, I see the service listed in the runlevel 2-3-4-5

However the service doesn’t start when I reboot.

Any help?

I’ve upgraded to Wowza Streaming Engine 4.1.2 (I was in 4.1.0).

I thought it would fix the problem, but no luck.

Please any idea? :frowning:

Hey there,

So I made some tests. And here is the thing: when I install Wowza Streaming Engine in the default folder /usr/local/, there is no problem, Wowza automatically starts at reboot.

But if I move the program somewhere else (for example: /home/wowza), I change the symbolic link and reboot, the service doesn’t start.

I really don’t understand. Can you help me?

It works!! Thank you! :slight_smile:

I had my Wowza Streaming Engine stop starting after upgrading to Fedora 22.

removed symlink /etc/init.d/WowzaStreamingEngine

removed symlink /etc/init.d/WowzaStreamingEngineManager

create file: /usr/lib/systemd/system/WowzaStreamingEngine.service

ExecStart=/usr/local/WowzaStreamingEngine/bin/WowzaStreamingEngine start
ExecStop=/usr/local/WowzaStreamingEngine/bin/WowzaStreamingEngine start
# Give a reasonable amount of time for the server to start up/shut down

create file: /usr/lib/systemd/system/WowzaStreamingEngineManager.service

ExecStart=/usr/local/WowzaStreamingEngine/manager/bin/WowzaStreamingEngineManager start
ExecStop=/usr/local/WowzaStreamingEngine/manager/bin/WowzaStreamingEngineManager start
# Give a reasonable amount of time for the server to start up/shut down

turn on new Wowza services (as root)

systemctl daemon-reload
systemctl enable WowzaStreamingEngine.service
systemctl enable WowzaStreamingEngineManager.service

start new Wowza services (as root)

systemctl start WowzaStreamingEngine.service
systemctl start WowzaStreamingEngineManager.service