Results 1 to 4 of 4

Thread: rtmp H.264 input TO HLS/http (iOs) H.264 out

  1. #1
    Join Date
    Jan 2011
    Posts
    11

    Default rtmp H.264 input TO HLS/http (iOs) H.264 out

    Background: I've built a web-based app that makes it push button launch Wowza's devpay AMI's on AWS (in any size or region). The first server that loads for a given event is the origin server; you can then launch edge servers at will. (I've also automated a player embed tag that goes along with the configuration to make it truly work.)
    I'm wondering... the origin takes an H.264 encoded rtmp stream. Can I create an edge configuration option for a server that gets the stream from the origin and delivers it as HLS, which I understand is HTTP without the transcoder plugin... assuming the rtmp stream is already H.264; this isn't really a transcode; just an alternate delivery protocol. And this would have to be possible using the off-the-shelf AMI's; I don't want to customize the AMI beyond Application configurations. Any pointers are greatly appreciated. I've combed through forums and looked at documentation; I think I'm just not quite sure where to start.

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    You don't need the Wowza Transcoder for HLS (cupertinostreaming). With LiveRepeater, packetizing is done on the origin. Take a look at this guide:

    http://www.wowza.com/forums/content....er-Quick-Start

    Richard

  3. #3
    Join Date
    Jan 2011
    Posts
    11

    Default

    Richard,
    Thank you for the link. Very helpful. With proper server configuration; then I assume you configure the player like
    http://[wowza-address]/[application]/[application-instance]/[stream-name]/playlist.m3u8
    as documented here: http://www.wowza.com/forums/content....tinostreaming?

    Warren
    webvideodesk.com

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Right

Similar Threads

  1. http streaming (h.264)
    By amit79 in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 1
    Last Post: 04-27-2013, 02:59 AM
  2. H.264 flash works but H.264 MP4 doesn't
    By MAXDigital in forum Live Streaming and Encoder Discussion
    Replies: 2
    Last Post: 08-29-2012, 01:20 PM
  3. H.264/Speex To iOS Encoding Problem - No Audio
    By ImAStreamer in forum AddOn: Transcoder
    Replies: 1
    Last Post: 08-16-2012, 02:31 PM
  4. Replies: 1
    Last Post: 05-07-2012, 05:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •