Results 1 to 8 of 8

Thread: Smooth Streaming with 2sec chunks

  1. #1

    Default Smooth Streaming with 2sec chunks

    I have some content with 2sec chunks for various bitrates in ismv files.

    So i have almsot 6 bitrates with 6 ismv file and each have 2 sec chunked data.

    I also have ism file as manifest.

    Now, when i try to play tht with Wowza, server gives the error as unable to play as manifest got error.

    When i play with some other media server it works fine.

    I am playing on RHEL.

    ANy debug info for that will be helpful

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Are you using "smil:" prefix for the ism file?

    http://[wowza-address]:1935/vod/smil:medialist.ism/Manifest

    Richard

  3. #3

    Default

    yeah, i am using the smil prefix but still the same error:

    Streaming Error: Caught exception trying to parse main manifest: At least one media stream is needed, none are declared in the manifest.


    Error log shows the NullPointerException..! not sure what exactly is causing the issue..!

    Also, when i play the mp4 file, it works well with the following URL:

    http://192.168.1.7:1935/vod/mp4:airtime.mp4/Manifest

    in the same location, I have copied the ismv file and ism files. Now, i play the following URL:

    http://192.168.1.7:1935/vod/smil:airtime.ism/Manifest then it shows the error:

    Streaming Error: Caught exception trying to parse main manifest: At least one media stream is needed, none are declared in the manifest.
    Last edited by nitinkumgoyal; 03-11-2013 at 07:41 AM.

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    If you are encoding multiple bit rate versions to one ismv file, which you can do with Expression 4 Encoder, that won't work in Wowza. They need to be separate files.

    We really don't recommend this encoding path using Expression 4 Encoder. It can work, but the .ismv files are fragmented mp4 files and incur substantial added overhead, especially right at the beginning of client playback.

    Take a look at this guide to encoding vod content, which includes pre-sets for E4E

    http://www.wowza.com/forums/content....demand-content

    E4E does not produce ism files using this method, you will have to make a smil file. If you are targeting iOS it is a good idea to add codec and resolution info to the smil:
    http://www.wowza.com/forums/content....to-iOS-streams

    Richard

  5. #5

    Default

    Nopes, there are multiple bitrates file, each file for each bitrate but they are chunked as 2 sec chunks. The issue i see is that hte player is not able to read the manifest at all as when i open the URL it shows some default xml:

    This XML file does not appear to have any style information associated with it. The document tree is shown below.
    <SmoothStreamingMedia MajorVersion="2" MinorVersion="1" Timescale="10000000" Duration="0"></SmoothStreamingMedia>

    which is not mine. So, do you see nay particular configuration issue which i may need to solve by putting some change sin Application.xml or something.

    Also, i have edited my above comment with more details which may help.

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Hm, empty manifest, duration is "0".

    Does sample.mp4 work in your setup? http://localhost:1935/vod/mp4:sample.mp4/Manifest

    Do you get a proper manifest from one of the ismv files? Use mp4: prefix like this: http://localhost:1935/vod/mp4:yourVideo.ismv/Manifest

    Richard

  7. #7

    Default

    yeah the mp4 files works perfectly..

    the manifest looks good as given by the encoder and it worked perfectly on another streamer like Unified Streaming.

    The mp4 prefix with ismv is not working and the error says moov atom not found.

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    How was it encoded? I assume you used Expression 4 Encoder. What video and audio settings? Does it play in VLC directly (not streamed from Wowza)? If so, what does VLC report in Tools > Codec Info?

    Richard

Similar Threads

  1. Replies: 5
    Last Post: 03-04-2013, 03:00 PM
  2. Cupertino streaming playlist shows mp3 instead of ts chunks
    By jland138 in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 02-16-2012, 03:19 PM
  3. Replies: 3
    Last Post: 11-25-2011, 05:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •