Results 1 to 10 of 10

Thread: Wowza Blcoked my IP

  1. #1
    Join Date
    Feb 2014
    Posts
    4

    Default Wowza Blcoked my IP

    Hi, after install Wowza Streaming Engine (in Azure) and open all ports i tryed to open the Engine Manager and after login i get a error XML saying that my IP has been blocked. How unlock my IP? What reasons this blocking happen?

  2. #2
    Join Date
    May 2013
    Posts
    681

    Default

    It sounds as though you might need to whitelist your IP.

  3. #3
    Join Date
    Feb 2014
    Posts
    4

    Default

    That was it, thanks, i inserted * in whitelist property.
    One more detail, i received XML response because i trying to access Engine Manager on port 8087 and this port is for REST API, myip:8088 is inaccessible (this port are open on Azure), any idea why port 8088 its inaccessible?
    Now on myip:8087 i get error XML like previous with message "REST API is not licensed".

  4. #4
    Join Date
    Jun 2013
    Posts
    20

    Default

    Matheus,

    provavelmente o WSE Manager está desligado, vc pode instalar o serviço (InstallWowzaStreamingEngineManager-Service.bat) ou liga-lo sob standalone (startmgr.bat), dá uma olhada na pasta: wowza\manager\bin

    Luis
    Last edited by lgbmdev; 02-27-2014 at 07:28 AM.

  5. #5
    Join Date
    Feb 2014
    Posts
    4

    Default

    Obrigado, resolvi aqui, era isso mesmo.

  6. #6
    Join Date
    Sep 2011
    Posts
    1,920

    Default

    Hi,
    Please post all responses in English.

    Thanks,
    Jason

  7. #7

    Default

    Hi all,

    we´re testing REST api and we are able to access the documentation and test it. But, when we want to restrict access to the documentation and the use to the methods, I fill in the IP address which is authorized to access in ipwhitelist (Server.xml)... but after doing that I lose access to the Wowza Streaming Engine Manager, it says that the access is blocked. I understand that the problem is the IP in ipwhitelist. I would like to restrict access to documentation and methos in REST api but not to WSEM. Any Idea? Thanks.

  8. #8
    Join Date
    Sep 2011
    Posts
    1,920

    Default

    Hi,
    Please do not post the same question in multiple places.
    I can see you asked this question HERE.

    Jason

  9. #9

    Default

    getting "REST API is not licensed"

    <error>
    <wowzaServer>4.0</wowzaServer>
    <code>402</code>
    <message>REST API is not licensed</message>
    </error>

    on accessing REST methods at http://<wowzaserverip>:8087

    Cant even open it from RESTAPIDocumentationWebpage/index.html as it reads CORS issue on http://<wowzaserverip>:8089/api-docs

    my server.xml look as follows :

    <?xml version="1.0" encoding="UTF-8"?>
    <Root version="2">
    <Server>
    <Name>Wowza Streaming Engine</Name>
    <Description>Wowza Streaming Engine is robust, customizable, and scalable server software that powers reliable streaming of high-quality video and audio to any device, anywhere.</Description>
    <RESTInterface>
    <Enable>true</Enable>
    <IPAddress>*</IPAddress>
    <Port>8087</Port>
    <!-- none, basic, digest-->
    <AuthenticationMethod>digest</AuthenticationMethod>
    <DiagnosticURLEnable>false</DiagnosticURLEnable>
    <SSLConfig>
    <Enable>false</Enable>
    <KeyStorePath></KeyStorePath>
    <KeyStorePassword></KeyStorePassword>
    <KeyStoreType>JKS</KeyStoreType>
    <SSLProtocol>TLS</SSLProtocol>
    <Algorithm>SunX509</Algorithm>
    <CipherSuites></CipherSuites>
    <Protocols></Protocols>
    </SSLConfig>
    <IPWhiteList>*</IPWhiteList>
    <IPBlackList></IPBlackList>
    <EnableXMLFile>false</EnableXMLFile>
    <DocumentationServerEnable>true</DocumentationServerEnable>
    <DocumentationServerPort>8089</DocumentationServerPort>
    <!-- none, basic, digest-->
    <DocumentationServerAuthenticationMethod>none</DocumentationServerAuthenticationMethod>
    <Properties>
    <Property>
    <Name>restUserHTTPHeaders</Name>
    <Value>Access-Control-Allow-Origin:*|Access-Control-Allow-Methods:OPTIONS,GET,PUT,DELETE,POST</Value>
    </Property>
    </Properties>
    </RESTInterface>
    <CommandInterface>
    <HostPort>
    <ProcessorCount>${com.wowza.wms.TuningAuto}</ProcessorCount>
    <IpAddress>*</IpAddress>
    <Port>8083</Port>
    </HostPort>
    </CommandInterface>
    <AdminInterface>
    <!-- Objects exposed through JMX interface: Server, VHost, VHostItem, Application, ApplicationInstance, MediaCaster, Module, Client, MediaStream, SharedObject, Acceptor, IdleWorker -->
    <ObjectList>Server,VHost,VHostItem,Application,ApplicationInstance,MediaCaster,Module,IdleWorker</ObjectList>
    </AdminInterface>
    <Stats>
    <Enable>true</Enable>
    </Stats>
    <!-- JMXUrl: service:jmx:rmi://localhost:8084/jndi/rmi://localhost:8085/jmxrmi -->
    <JMXRemoteConfiguration>
    <Enable>false</Enable>
    <IpAddress>${com.wowza.amazonaws.ec2.AWSEC2_METADATA_PUBLIC_HOSTNAME}</IpAddress>
    <!-- set to localhost or internal ip address if behind NAT -->
    <RMIServerHostName>${com.wowza.amazonaws.ec2.AWSEC2_METADATA_PUBLIC_HOSTNAME}</RMIServerHostName>
    <!-- set to external ip address or domain name if behind NAT -->
    <RMIConnectionPort>8084</RMIConnectionPort>
    <RMIRegistryPort>8085</RMIRegistryPort>
    <Authenticate>true</Authenticate>
    <PasswordFile>${com.wowza.wms.ConfigHome}/conf/jmxremote.password</PasswordFile>
    <AccessFile>${com.wowza.wms.ConfigHome}/conf/jmxremote.access</AccessFile>
    <SSLSecure>false</SSLSecure>
    </JMXRemoteConfiguration>
    <UserAgents>Shockwave Flash|CFNetwork|MacNetwork/1.0 (Macintosh)</UserAgents>
    <Streams>
    <DefaultStreamPrefix>mp4</DefaultStreamPrefix>
    </Streams>
    <ServerListeners>
    <ServerListener>
    <BaseClass>com.wowza.wms.plugin.amazonaws.ec2.env.ServerListenerEC2Variables</BaseClass>
    </ServerListener>
    <ServerListener>
    <BaseClass>com.wowza.wms.mediacache.impl.MediaCacheServerListener</BaseClass>
    </ServerListener>
    <!--
    <ServerListener>
    <BaseClass>com.wowza.wms.plugin.loadbalancer.ServerListenerLoadBalancerListener</BaseClass>
    </ServerListener>
    -->
    <!--
    <ServerListener>
    <BaseClass>com.wowza.wms.plugin.loadbalancer.ServerListenerLoadBalancerSender</BaseClass>
    </ServerListener>
    -->
    </ServerListeners>
    <VHostListeners>
    <!--
    <VHostListener>
    <BaseClass></BaseClass>
    </VHostListener>
    -->
    </VHostListeners>
    <HandlerThreadPool>
    <PoolSize>${com.wowza.wms.TuningAuto}</PoolSize>
    </HandlerThreadPool>
    <TransportThreadPool>
    <PoolSize>${com.wowza.wms.TuningAuto}</PoolSize>
    </TransportThreadPool>
    <RTP>
    <DatagramStartingPort>6970</DatagramStartingPort>
    <DatagramPortSharing>false</DatagramPortSharing>
    </RTP>
    <Manager>
    <!-- Properties defined are used by the Manager -->
    <Properties>
    </Properties>
    </Manager>
    <!-- Properties defined here will be added to the IServer.getProperties() collection -->
    <Properties>
    </Properties>
    </Server>
    </Root>

  10. #10
    Join Date
    Sep 2011
    Posts
    1,920

    Default

    Hi,
    Please update to the latest version, I believe the REST API was not available with a subscription license in the earlier versions of Wowza Streaming Engine (built when the REST API was in private preview).

    Regards,
    Jason
    Last edited by JasonH; 11-17-2015 at 05:05 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •