Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Dlink dcs-933 l

  1. #1

    Default Dlink dcs-933 l

    Hi

    I bought a Dlink DCS-933L today, I am done with the initial setup, i am able to watch my video live on mydlink portal.

    I tried to watch the live stream on VLC media player using rtsp://[cameraIP]:554/live1.sdp

    I am NOT able to watch my live stream on VLC. Can some one help me on this issue?

    Here CameraIP is the public ip, which i got from the ISP right?
    Do i need to make any changes to my wireless router?

  2. #2
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    IP cameras have their own IP address. It is the same IP address you use to access its manager. This is the basic guide to using IP cameras with Wowza.

    And this is reference for IP cameras that might be useful.

    Richard

  3. #3

    Smile

    i didn't receive any ip address from dlink. Will I? I am accessing the camera using my.dlink.com portal.

    Do i need to do port forwarding on my wireless router?
    Last edited by nkkrishna; 07-06-2014 at 02:47 AM.

  4. #4
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Yes, you do need to do port forwarding of port 554 (rtsp).

    Connected to your router, the IP of the camera will internal IP like 192.168.1.x

    Richard

  5. #5

    Cool

    I did that, but still no luck. I did port forwarding of port 554, to my ip camera (192.168.1.33),

    I used the following URL on my LAN rtsp://192.168.1.33:554/live1.sdp
    I used the following URL on my WAN rtsp://117.216.112.206:554/live1.sdp

    Still i am not able to view my video on VLC. Can you help me with that.
    Last edited by nkkrishna; 07-07-2014 at 08:35 AM.

  6. #6
    Join Date
    Jul 2012
    Posts
    302

    Default

    Hi,

    Is there a username and password required for your camera? If so, often the use convention resembles this URL:

    rtsp://username:password@192.168.1.33:554/live1.sdp
    rtsp://username:password@117.216.112.206:554/live1.sdp
    -Tim

  7. #7

    Default

    Hi
    Yes camera has a username and password. Tried that too, but noluck.

  8. #8
    Join Date
    Jul 2012
    Posts
    302

    Default

    We need to get a better idea of what's happening in transport from the source. I would suggest further attempts in VLC, using debug mode, which is explained here:

    Advanced use of VLC

    Also, have a look at the packets by listening to the camera IP using Wireshark.

    Please keep us posted on your progress.

    -Tim

  9. #9

    Smile

    Hi Tim

    Please find the logs from VLC below
    main debug: adding item `rtsp://192.168.1.33:554/live1.sdp' ( rtsp://admin:test123@192.168.1.33:554/live1.sdp )
    qt4 debug: Adding a new MRL to recent ones: rtsp://admin:test123@192.168.1.33:554/live1.sdp
    main debug: no fetch required for (null) (art currently (null))
    main debug: rebuilding array of current - root Playlist
    main debug: rebuild done - 1 items, index -1
    main debug: processing request item: rtsp://192.168.1.33:554/live1.sdp, node: null, skip: 0
    main debug: resyncing on rtsp://192.168.1.33:554/live1.sdp
    main debug: rtsp://192.168.1.33:554/live1.sdp is at 0
    main debug: starting playback of the new playlist item
    main debug: resyncing on rtsp://192.168.1.33:554/live1.sdp
    main debug: rtsp://192.168.1.33:554/live1.sdp is at 0
    main debug: creating new input thread
    main debug: Creating an input for 'rtsp://192.168.1.33:554/live1.sdp'
    main debug: using timeshift granularity of 50 MiB, in path 'C:\Users\Mahesh\AppData\Local\Temp'
    main debug: `rtsp://admin:test123@192.168.1.33:554/live1.sdp' gives access `rtsp' demux `' path `admin:test123@192.168.1.33:554/live1.sdp'
    main debug: creating demux: access='rtsp' demux='' location='admin:test123@192.168.1.33:554/live1.sdp' file='\\admin:test123@192.168.1.33:554\live1.sdp'
    main debug: looking for access_demux module: 1 candidate
    qt4 debug: IM: Setting an input
    live555 debug: version 2012.12.18
    live555 debug: connection error -10057
    live555 error: Failed to connect with rtsp://admin:test123@192.168.1.33:554/live1.sdp
    main debug: no access_demux module matching "rtsp" could be loaded
    main debug: TIMER module_need() : 2101.460 ms - Total 2101.460 ms / 1 intvls (Avg 2101.460 ms)
    main debug: creating access 'rtsp' location='admin:test123@192.168.1.33:554/live1.sdp', path='\\admin:test123@192.168.1.33:554\live1.sdp'
    main debug: looking for access module: 1 candidate
    main debug: net: connecting to admin port 0
    main error: cannot resolve admin port 0 : No such host is known.
    access_realrtsp error: cannot connect to admin:0
    access_realrtsp debug: could not connect to: admin:test123@192.168.1.33:554/live1.sdp
    main debug: no access module matching "rtsp" could be loaded
    main debug: TIMER module_need() : 2601.871 ms - Total 2601.871 ms / 1 intvls (Avg 2601.871 ms)
    main error: open of `rtsp://admin:test123@192.168.1.33:554/live1.sdp' failed
    main debug: dead input
    main debug: changing item without a request (current 0/1)
    main debug: nothing to play
    qt4 debug: IM: Deleting the input
    main debug: TIMER input launching for 'rtsp://192.168.1.33:554/live1.sdp' : 4760.453 ms - Total 4760.453 ms / 1 intvls (Avg 4760.453 ms)

    Last edited by nkkrishna; 07-07-2014 at 07:58 PM.

  10. #10

    Wink

    Hi

    I am able to view my live video on VLC using HTTP url,

    http://admin:password@122.x.x.x:554/video.cgi
    I followed these instructions

    I am able to connect to Camera.stream without any issues,but I am NOT able to watch the camera stream on the test player

    I am getting "Waiting for Stream" in "Incoming Streams"

    I tried the following for RTSP, but no success
    rtsp://username:password@122.164.x.x:554/live1.sdp
    rtsp://username:password@192.168.x.x:554/live1.sdp
    Can anyone help on this issue.
    Last edited by nkkrishna; 07-19-2014 at 09:41 PM.

Page 1 of 3 123 LastLast

Similar Threads

  1. Flash Player crashes on RTSP Re-streaming from D-Link DCS-942L and TrendNET TV-IP572W
    By Daniel6 in forum Live Streaming and Encoder Discussion
    Replies: 16
    Last Post: 04-12-2013, 12:28 PM
  2. DLink DCS-6113 and Wowza
    By 704114@mail.ru in forum General Forum
    Replies: 4
    Last Post: 02-18-2012, 06:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •