Results 1 to 9 of 9

Thread: ERROR: Client is not in list of valid encoders.

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Aug 2014

    Default ERROR: Client is not in list of valid encoders.

    I built Wowza Streaming Engine 4.0.6 on EC2, and am trying to publish live stream from Elemental Live hardware encoder.

    I made sure that the Wowza server works well with GoCoder app, but doesn't work with Elemental Live hardware encoder.

    According to the error log on Elemental Live encoder,

    2014-08-19 07:54:15 I RTMP mediaID [25] successfully connected to server [Connection succeeded.] [FMS/3,5,7,7009] []
    2014-08-19 07:54:15 I RTMP mediaID [25] server URI is [rtmp://999.999.999.999/livexxxxx]
    2014-08-19 07:54:15 I RTMP mediaID [25] calling server-side FCPublish.
    2014-08-19 07:54:15 I RTMP mediaID [25] stream name is [myStream]
    2014-08-19 07:54:15 I RTMP mediaID [25] stream created successfully.
    2014-08-19 07:54:15 I RTMP mediaID [25] connection message [NetStream.Publish.Denied] [RTMP Publishing not allowed. Client is not in list of valid encoders.] [] []

    It seems that the hardware encoder is denied from valid encoder list. I couldn't find any info about the valid encoder list on the Internet. How can I make my encoder allowed to publish?



  2. #2



    Do you see anything being written out in the Wowza access logs? I'm wondering if it's connecting with Wowza is rejecting the connections due to invalid Flash version string (Engine Manager > App name > Outbound security). See if disabling security helps or at least rules that out. Maybe also disabling any user based credentials on Wowza and set your Elemental encoder not to require rtmp authentication (if it has that option).

    Last edited by Paul_S; 08-19-2014 at 03:11 AM. Reason: added info

  3. #3
    Join Date
    Aug 2014


    Hi Paul,
    Thank you for your advice.

    I checked the Wowza log and found the device name of my hardware encoder, which is "Elemental Live / (compatible; MSS/1.0)"

    According to the How to configure security using Wowza Streaming Engine Manager page you mentioned,
    Engine Manager > App name > Incoming Security > Flash Version String checks encoder manufacturer.

    I put "Elemental Live" into Flash Version String field, then it became working.

    Thank you so much.


  4. #4


    Masa, thanks for the update and glad you were able to get this sorted.


  5. #5
    Join Date
    Feb 2015


    This solution also worked for me using a Teradek Vidiu Encoder. I had to put "Teradek/1.0 (compatible; FMSc/1.0)" under Flash Version String. It was -not set- before on Wowza version version 4.0.4. Thanks save me a bunch of frustration!

  6. #6


    Thanks for this info mzmiller. It is likely to help people in the future.

    Welcome to the Wowza support forum and please let us know if there is anything we can help you with down the road.



  7. #7
    Join Date
    Dec 2015


    I have the same error message "Android RTMP publish not allowed. Client is not a list of valid encoders", while run on Android "OS BROADCASTER" (Live RTMP streamer), (C) Olobon soft. Video codec: Sorenson Spark, Audio codec: Speex, NellyMoser.

Similar Threads

  1. List of Encoders for Wowza
    By GameDayXtra in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 06-21-2012, 12:07 AM
  2. Not valid stream name error
    By danaronson in forum Video On Demand Streaming Discussion
    Replies: 19
    Last Post: 04-09-2012, 03:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts