Results 1 to 7 of 7

Thread: Removed app cheking by wowza

  1. #1

    Question Removed app cheking by wowza

    Good afternoon!
    I need to rename 1 app to another. Now I understand that I need to copy app. But today I renamed it by hand in linux console (rename in conf, application folders, and in conf file). And now in wowza logs i see that wowza check this apps and of course, a lot of errors have been written in log file. I tryed to create this app once again and then delete, restart app, restart wowza server. But in any case I see this errors. Please help me! It's very important!
    I don't understand where is this cache.

  2. Default

    Hi livestreamingforall welocme to the forums xD

    If you could pose up your config for the application as well as your log files (access & error) we will be able to better assist you.

    Polite Reminder: When posting log, config or any other kind of file that contains a large quantity of information be sure to wrap that information in the "[code ]" and "[/code ]" (removing the space) board tags.


    Kind Regards

    Lee.

  3. #3

    Default

    Quote Originally Posted by lee.wickham View Post
    Hi livestreamingforall welocme to the forums xD

    If you could pose up your config for the application as well as your log files (access & error) we will be able to better assist you.

    Polite Reminder: When posting log, config or any other kind of file that contains a large quantity of information be sure to wrap that information in the "[code ]" and "[/code ]" (removing the space) board tags.


    Kind Regards

    Lee.
    Not a problem!

    Error log:
    - - - - RESTServer: Bind failed, try again ([any]:8087): java.net.BindException: Address already in use|at sun.nio.ch.Net.bind0(Native Method)|at sun.nio.ch.Net.bind(Net.java:444)|at sun.nio.ch.Net.bind(Net.java:436)|at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:214)|at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)|
    WARN server comment 2015-01-12	19:20:32 - - - - - 9164.982 - - - -- - - - Application folder ([install-location]/applications/ipcam_re) is missing
    WARN server comment 2015-01-12	19:20:34 - - - - - 9167.425 - - - -- - - - Application folder ([install-location]/applications/ipcam) is missing
    WARN server comment 2015-01-12	19:20:34 - - - - - 9167.427 - - - -- - - - Application folder ([install-location]/applications/ipcam) is missing
    WARN server comment 2015-01-12	19:20:35 - - - - - 9168.014 - - - -- - - - Application folder ([install-location]/applications/ipcam_re) is missing
    WARN server comment 2015-01-12	19:20:36 - - - - - 6874.539
    ...
    
    WARN server comment 2015-01-12	19:20:41 - - - - - 6879.545 - - - -- - - - RESTServer: Bind failed, try again ([any]:8087): java.net.BindException: Address already in use|at sun.nio.ch.Net.bind0(Native Method)|at sun.nio.ch.Net.bind(Net.java:444)|at sun.nio.ch.Net.bind(Net.java:436)|at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:214)|at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)|
    WARN server comment 2015-01-12	19:20:43 - - - - - 9176.43 - - - - -- - - Application folder ([install-location]/applications/ipcam) is missing
    WARN server comment 2015-01-12	19:20:43 - - - - - 9176.431 - - - -- - - - Application folder ([install-location]/applications/ipcam) is missing
    WARN server comment 2015-01-12	19:20:44 - - - - - 9177.013 - - - -- - - - Application folder ([install-location]/applications/ipcam_re) is missing
    WARN server comment 2015-01-12	19:20:46 - - - - - 9179.427 - - - -- - - - Application folder ([install-location]/applications/ipcam) is missing
    WARN server comment 2015-01-12	19:20:46 - - - - - 9179.428 - - - -- - - - Application folder ([install-location]/applications/ipcam) is missing
    Access log:
    2015-01-12	19:22:55 MSK connect-pending session INFO 100 192.168.71.1 - _defaultVHost_ - - 0.004 [any] 1935 rtmp://[ip-of-the-server]:1935/ipcam/_definst_ 192.168.71.1 wowz WowzaProLiveRepeater WIN 10,0,12,36 141375741	3405 3073 - - - - - - - - - - - - -rtmp://[ip-of-the-server]:1935/ipcam/_definst_ -
    2015-01-12	19:22:55 MSK connect session INFO 404 192.168.71.1 - _defaultVHost_ - - 0.005 [any] 1935 rtmp://[ip-of-the-server]:1935/ipcam/_definst_ 192.168.71.1 wowz WowzaProLiveRepeater WIN 10,0,12,36 141375741	3405 3073 - - - - - - - - - - - - -rtmp://[ip-of-the-server]:1935/ipcam/_definst_ -
    2015-01-12	19:22:55 MSK comment server INFO 200 - LiveMediaStreamReceiver.onResult: Error Connecting to remote server: code: NetConnection.Connect.Rejected - - - 9308.472 - - - - - -- - - - - - - - - - - - - - - - - --
    2015-01-12	19:22:55 MSK comment server WARN 200 - Application folder ([install-location]/applications/ipcam) is missing - - - 9308.472 - - - - - - - - - -- - - - - - - - - - - - - - -
    2015-01-12	19:22:55 MSK comment server INFO 200 - LiveMediaStreamReceiver.sessionClosed[ipcam/_definst_/mp4:restream/petergof.stream] - - - 9308.473 - - - - - - - -- - - - - - - - - - - - - - - - -
    2015-01-12	19:22:55 MSK disconnect session INFO 200 141375741	- _defaultVHost_ - - 0.008 [any] 1935 rtmp://[ip-of-the-server]:1935/ipcam/_definst_ 192.168.71.1 wowz WowzaProLiveRepeater WIN 10,0,12,36 141375741	3405 3284 - - - - - - - - - - - - -rtmp://[ip-of-the-server]:1935/ipcam/_definst_ -
    2015-01-12	19:22:55 MSK connect-pending session INFO 100 192.168.71.1 - _defaultVHost_ - - 0.003 [any] 1935 rtmp://[ip-of-the-server]:1935/ipcam/_definst_ 192.168.71.1 wowz WowzaProLiveRepeater WIN 10,0,12,36 882225748	3405 3073 - - - - - - - - - - - - -rtmp://[ip-of-the-server]:1935/ipcam/_definst_ -
    2015-01-12	19:22:55 MSK comment server INFO 200 - LiveMediaStreamReceiver.sessionClosed[ipcam/_definst_/mp4:restream/petergof.stream]: reconnect: isCurrentSession:true tryConnect:true - - - 9308.474 - -- - - - - - - - - - - - - - - - - -- - - - -
    2015-01-12	19:22:55 MSK connect session INFO 404 192.168.71.1 - _defaultVHost_ - - 0.008 [any] 1935 rtmp://[ip-of-the-server]:1935/ipcam/_definst_ 192.168.71.1 wowz WowzaProLiveRepeater WIN 10,0,12,36 882225748	3405 3073 - - - - - - - - - - - - -rtmp://[ip-of-the-server]:1935/ipcam/_definst_ -
    2015-01-12	19:22:55 MSK comment server INFO 200 - LiveMediaStreamReceiver.onResult: Error Connecting to remote server: code: NetConnection.Connect.Rejected - - - 9308.48 - - - - - - -- - - - - - - - - - - - - - - - - -
    2015-01-12	19:22:55 MSK comment server INFO 200 - LiveMediaStreamReceiver.sessionClosed[ipcam/_definst_/mp4:restream/usa-streaming.stream] - - - 9308.481 - - - - - - - -- - - - - - - - - - - - - - - - -
    2015-01-12	19:22:55 MSK comment server INFO 200 - LiveMediaStreamReceiver.sessionClosed[ipcam/_definst_/mp4:restream/usa-streaming.stream]: reconnect: isCurrentSession:true tryConnect:true - - - 9308.482 - -- - - - -

    And by the way, I killed ipcam app and of course, i don't have a code. but wowza try to use this app anyway.

    And what I see in "live" logs in standalone mode:
    INFO session connect 192.168.71.1 -
    INFO server comment - LiveMediaStreamReceiver.onResult: Error Connecting to remote server: code: NetConnection.Connect.Rejected
    INFO server comment - LiveMediaStreamReceiver.sessionClosed[ipcam_re/_definst_/mp4:restream/petergof.stream]
    INFO server comment - LiveMediaStreamReceiver.sessionClosed[ipcam_re/_definst_/mp4:restream/petergof.stream]: reconnect: isCurrentSession:true tryConnect:true
    INFO session disconnect 1730575063 -
    WARN server comment - Application folder ([install-location]/applications/ipcam) is missing
    INFO session connect-pending 192.168.71.1 -
    INFO session connect 192.168.71.1 -
    INFO server comment - LiveMediaStreamReceiver.onResult: Error Connecting to remote server: code: NetConnection.Connect.Rejected
    INFO server comment - LiveMediaStreamReceiver.sessionClosed[ipcam/_definst_/mp4:restream/usa-streaming.stream]
    INFO server comment - LiveMediaStreamReceiver.sessionClosed[ipcam/_definst_/mp4:restream/usa-streaming.stream]: reconnect: isCurrentSession:true tryConnect:true
    INFO session disconnect 2087333608 -
    WARN server comment - Application folder ([install-location]/applications/ipcam) is missing
    INFO session connect-pending 192.168.71.1 -
    INFO session connect 192.168.71.1 -
    INFO server comment - LiveMediaStreamReceiver.onResult: Error Connecting to remote server: code: NetConnection.Connect.Rejected
    INFO server comment - LiveMediaStreamReceiver.sessionClosed[ipcam/_definst_/mp4:restream/petergof.stream]
    INFO session disconnect 1493773255 -
    INFO server comment - LiveMediaStreamReceiver.sessionClosed[ipcam/_definst_/mp4:restream/petergof.stream]: reconnect: isCurrentSession:true tryConnect:true
    WARN server comment - Application folder ([install-location]/applications/ipcam_re) is missing
    INFO session connect-pending 192.168.71.1 -
    INFO session connect 192.168.71.1 -
    INFO server comment - LiveMediaStreamReceiver.on
    Last edited by livesreamingforall; 01-12-2015 at 08:37 AM.

  4. #4

    Default

    Hello there.

    A couple things you might try are:
    1: Shut down Wowza and the Engine Manager. It seems like the Engine Manager was already running when you last started Wowza. Either that or you have some other application running on that port.
    How to start and stop Wowza Streaming Engine software
    Wowza requires ports 8086-8088 for administration and to support the REST API, which is the link between Wowza Streaming Engine and the GUI. Make sure you have these ports available on the host. As a reference:
    Configure streaming ports

    It could be that Wowza was not restarted successfully after these changes were made.

    2: Please confirm that you have a matching set of folders that correspond to the name change of the application:
    [install-dir]/applications/ipcam (or whatever the new name is)
    [install-dir]/conf/ipcam/Application.xml

    Or if you are trying to remove the application entirely, remove the /conf/ipcam directory as well.

    3: Did you configure /conf/StartupStreams.xml to reference the application that has be removed/renamed?

    I hope this helps.

    Kind regards,

    Salvadore

  5. #5

    Default

    Quote Originally Posted by salvadore View Post
    Hello there.

    A couple things you might try are:
    1: Shut down Wowza and the Engine Manager. It seems like the Engine Manager was already running when you last started Wowza. Either that or you have some other application running on that port.
    How to start and stop Wowza Streaming Engine software
    Wowza requires ports 8086-8088 for administration and to support the REST API, which is the link between Wowza Streaming Engine and the GUI. Make sure you have these ports available on the host. As a reference:
    Configure streaming ports

    It could be that Wowza was not restarted successfully after these changes were made.

    2: Please confirm that you have a matching set of folders that correspond to the name change of the application:
    [install-dir]/applications/ipcam (or whatever the new name is)
    [install-dir]/conf/ipcam/Application.xml

    Or if you are trying to remove the application entirely, remove the /conf/ipcam directory as well.

    3: Did you configure /conf/StartupStreams.xml to reference the application that has be removed/renamed?

    I hope this helps.

    Kind regards,

    Salvadore
    No, it didn't help.
    I try to shutdown wowza, engine manager, clear cached memory, delete /conf/ipcam, /applications/ipcam.
    In /conf/StartupStreams.xml I didn't write anything. But, I used in /conf/server.xml - startupstreamsmonitor previously for this app. But before I killed folders, I had deleted this string from this file. And after restart wowza, it monitor this app anyway(

    ..
    I try to clear value in name "startupStreamsMonitorApplicationList". And after it, everything is ok. But if I write some application (not ipcam or ipcam_re) that app start but ipcam start too...
    Last edited by livesreamingforall; 01-12-2015 at 10:14 PM.

  6. #6

    Default

    Thank you! I found the error! One of my app work as liverepeater and some streams restreams from ipcam.
    Thank you a lot!

  7. #7
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    That's great news.
    Thanks for the update.

    Regards,
    Jason

Similar Threads

  1. Have Wowza removed third AWS offering?
    By StudioTech TV in forum Wowza Streaming Engine in the Cloud
    Replies: 1
    Last Post: 04-07-2014, 02:20 PM
  2. removeApplication(String sName); call removed in VHost. How to do it now ?
    By Gpolox in forum Wowza Streaming Server Java API
    Replies: 1
    Last Post: 02-16-2014, 04:19 AM
  3. How to add external libraries in wowza app that work on standalone wowza server ?
    By rabelle.donovon in forum Server-side Modules and Code Samples Discussion
    Replies: 2
    Last Post: 07-13-2012, 07:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •