Results 1 to 6 of 6

Thread: One copy of the same subtitle for every format?

  1. #1
    Join Date
    Mar 2014
    Posts
    5

    Default One copy of the same subtitle for every format?

    Having a problem with .ttml multi language subtitle file to work correctly. If I duplicate the subtitle file to the same name as every format of the adaptive stream have, subtitles are shown. But if I just have a .ttml file with the original filename it does not.

    My setup;

    Physical files in folder;

    file_180p.mp4
    file_270p.mp4
    file_270p.mp4
    file_360p.mp4
    file_540p.mp4
    file_720p.mp4
    174297.ttml

    My SMIL-file;

    <smil>
    <head>
    </head>
    <body>
    <switch>
    <video src="mp4:174297_180.mp4" system-bitrate="400000"/>
    <video src="mp4:174297_270.mp4" system-bitrate="500000"/>
    <video src="mp4:174297_360.mp4" system-bitrate="900000"/>
    <video src="mp4:174297_540.mp4" system-bitrate="1300000"/>
    <video src="mp4:174297_720.mp4" system-bitrate="2000000"/>
    <textstream src="174297.ttml" system-language="swe,eng,par,spa,deu,nor">
    <param name="isWowzaCaptionStream" value="true" />
    </textstream>
    </switch>
    </body>
    </smil>

    With this setup, subtitles does not work.

    But, if I copy, or symlink the file 174297.ttml to the following, the subtitles work.

    file_180p.ttml
    file_270p.ttml
    file_270p.ttml
    file_360p.ttml
    file_540p.ttml
    file_720p.ttml

    How can I awoid this? I just want one subtitle file and let <wowza understand that this subtitle file can be used for all formats.

    As you have might guessed, I am doing adaptive streaming.

  2. #2

    Default

    Hi,

    The "textstream" parameter in your smil file should work. I've just done a quick test here and using a random xxxx.ttml file so long as it was in the smil file then Wowza would use that and allow me to flip through the different captions.

    I presume TTML is enabled for the app and the file does exist and is formatted correctly. It would certainly seem that way if it works with a symlink. It's as though it is ignoring the textstream statement. Does the player still show a list of languages in this format or are none shown at all? Are you on the latest patch update (now at 4.2). You can update via the "My Downloads" page in the customer portal.


    It may be best to contact us via the support process, also including a copy of your smil file and ttml file, and we can take a closer look. If possible enable CC debug properties first and try some playback tests again, just to capture a bit more detail.



    Paul

  3. #3
    Join Date
    Mar 2014
    Posts
    5

    Default

    Paul,

    Is it possible to hire Wowza for a 4-hour support session? I think you guys would be able to solve this amongst another problem we have, thumbnails in JWPlayer. Thumbnails are working when hosted at the web server but not when hosted in Wowza. I guess you know how it should be set up.

    Do you have paid support like this?

    We have possabillity to share screen and have full access to servers. I think with a joined session this would be solved in no time.

  4. #4

    Default

    Hi,

    Unfortunately, we don't provide support services outside of this forum (or via support@wowza.com for customers who are entitled to it). We do maintain a consultants list which you could request via the support email address, or you could ask in the Find a Consultant forum.


    Regards,

    Paul

  5. #5
    Join Date
    Mar 2014
    Posts
    5

    Default

    Actually Paul, problem was solved with 4.1.2 (4.2 that you mention is not available in "My downloads" page). We had the problem in 4.0.2. Now we have another strange problem, but that problem has been e-mailed to your support. Thank you!

  6. #6

    Default

    Hi,

    ok so some progress made which is great to know. 4.1.2 does contain a number of fixes. 4.2 - I prematurely mentioned, though it is due very soon - also includes a significant number of enhancements as well as fixes.

    We shall act on your support ticket immediately. Thanks for the update.


    Paul
    Last edited by Paul_S; 06-15-2015 at 10:51 AM.

Similar Threads

  1. Media Server integration with live streams (one-on-one, one-on-many),online chat,VOD
    By toth.csabi in forum Integrating Wowza into your workflow
    Replies: 2
    Last Post: 09-25-2014, 01:11 PM
  2. vod: video stops at same spot every time
    By bobmane in forum General Forum
    Replies: 5
    Last Post: 05-22-2014, 09:30 AM
  3. Replies: 7
    Last Post: 09-26-2013, 03:47 AM
  4. How to take snapshot of nDVR every one minute
    By db_2011 in forum AddOn: Wowza nDVR
    Replies: 10
    Last Post: 12-08-2011, 06:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •