Results 1 to 5 of 5

Thread: Re-stream ip camera

  1. #1
    Join Date
    Apr 2016

    Default Re-stream ip camera

    Hello everyone,
    I install wowza streaming engine on my server and try to re-stream RTSP ip camera.
    The stream is work well local. i test it and configure all the settings needed to get the stream ready for wowza engine.

    I tried wowza streaming engine on my local pc and i success sending the Stream File (the ip camera) to youtube.
    I didn't change any special settings - just followed the documents here.

    Today i installed wowza streaming engine on my server and i did the same, but now i get in Incoming Streams status line of the stream file Waiting for Stream instead of active.

    to make sure that i dont have problem with the RTSP link i connected to wowza cloud streaming and started to stream the ip camera with no problems.

    here are few logs, my guess it is something in the server:

    RTPSessionDescriptionDataProviderBasicRTSPWorker.doConnect: Connect org.apache.mina.common.RuntimeIOException: Failed to get the session[ConnectException: null].

    port 554 is opend in the server firewall
    UDP 6970 -9999 also opend

    please advice.

  2. #2



    You may want to try viewing your IP camera from the server using a player such as VLC, to ensure that the camera is accepting connections from your server.

    If that works, try enabling the additional RTSP debug logging in Wowza Streaming Engine to further troubleshoot these issues. See the instructions in the following article for help enabling these extra logging properties:

    How to add additional logging for RTSP debugging

    Once you have captured these logs, please submit your conf/ and logs/ directories to our Support Team by opening a ticket on this issue.

    Best regards,

  3. #3
    Join Date
    Apr 2016


    Thank you.

    Did exactly what you say.
    Do i need to start the stream before sending this files?

  4. #4
    Join Date
    Apr 2016


    An update:

    Notice everyone that see this errors, check again if the ports 554 and 1935 is open.
    I opend this ports via SSH and this didn't affect another firewall plugin that i have on my server. so you need to open this ports on the firewall manually

    Good luck.

  5. #5
    Join Date
    Sep 2011


    Thanks for the update and clarification on how you resolved the problem.


Similar Threads

  1. What IP camera should I use in order to publish audio back to the camera
    By mwallace in forum Live Streaming and Encoders
    Replies: 3
    Last Post: 06-03-2014, 09:34 AM
  2. Transcoding stream pulled from IP camera using .stream file
    By catdude in forum AddOn: Transcoder
    Replies: 4
    Last Post: 07-17-2012, 08:01 AM
  3. Video Chat Multiple Camera Not Streaming For Second Camera
    By emreVeriyaz in forum Live Streaming and Encoder Discussion
    Replies: 7
    Last Post: 06-01-2012, 02:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts