Results 1 to 4 of 4

Thread: How to find out, if a module works

  1. #1
    Join Date
    Apr 2016
    Posts
    2

    Default How to find out, if a module works

    Hi,

    I'm new to Wowza PlugIn Development and finished this tutorial:

    https://www.wowza.com/forums/content...#createproject

    Eclipse sucessfully created the .jar file in Wowza's lib folder, I also was able to add the module to an application via the web interface and it appears in the application's XML file, but it looks like the onAppStart()-method never triggers. I tried restarting the server, the application via the web interface, and I also restarted the service itself. Is there a way to check, if the module is available at all? The error log has no entries. Or can I somehow call the doSomething()-method that was created by the wizard manually, to check if the module works without relying on the events?

    Thanks a lot!

  2. #2
    Join Date
    Jan 2015
    Posts
    302

    Default

    Hi Rehakles,

    This would depend on what your custom module does. You can normally include additional logging information by calling the getLogger() method to troubleshoot your module. The doSomething method that is automatically generated is just an example module. You would still need to have a mechanism of calling the method from within your custom module. Can you post your custom code here? Alternatively, you can send in a developer support request if you would like to keep your code confidential.

    Michelle

    Michelle

  3. #3
    Join Date
    Apr 2016
    Posts
    2

    Default

    Hi Michelle,

    thanks for the reply. The code is the exact code from the linked tutorial (except the class and package name). We have now found out, that the module only triggers once a stream is started. The application start itself is not enough. Now we have the next error:

    comment server WARN 200 - loadModFunctions[live/_definst_]: Module class not found or could not be loaded. Check [install-dir]/conf/live/Application.xml to be sure all Modules/Module/Class paths are correct: name:ClassName class:com.somecompany.wowza.module - - - 12190.008

    The entry in the Application.xml seems to be correct though:

    <Module>
    <Name>ClassName</Name>
    <Description>ClassName</Description>
    <Class>com.somecompany.wowza.module</Class>
    </Module>


    Any ideas what could cause this error?

    Since were still trying out different approaches: Are PlugIns the correct way to go for automated publishing?
    What we are trying to accomplish is to automatically publish all new streams that are added to an application. We already have an external solution that re-writes the 'PushPublishMap.txt' file, which seems to work so far, but we thought that a PlugIn that uses the API might be the more robust way to do it.

    Thanks again

  4. #4

    Default

    Hi,

    Can you confirm that the jar file is located in /lib? The message does seem to indicate that it can't be located. If it is and you're sure it is named correctly and set up correctly in your application then zip up your /conf and /logs and /lib, open a support ticket and we can take a closer look.

    Paul

Similar Threads

  1. How can I find out the played vod video file name for Flash clients?
    By wtoolbox in forum Wowza Streaming Server Java API
    Replies: 2
    Last Post: 08-15-2014, 07:53 AM
  2. Live stream works everywhere except iOS HLS (where only audio works).
    By chocis in forum Live Streaming and Encoders
    Replies: 3
    Last Post: 04-23-2014, 09:24 AM
  3. How to find out unique users from Wowza logs ?
    By ampudhukode in forum General Forum
    Replies: 1
    Last Post: 11-21-2012, 02:20 PM
  4. How to find out which device is connected?
    By gcampanholi in forum Media Players and Devices Discussion
    Replies: 1
    Last Post: 05-02-2012, 10:02 PM
  5. Find out delay between startRecording call and first key frame
    By pokowaka in forum Server-side Modules and Code Samples Discussion
    Replies: 1
    Last Post: 04-03-2012, 02:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •