Wowza Community

Facebook live video interrupted

Our stream from Wowza to Facebook live My Timeline starts out fine. But…every 30 sec to a minute, Facebook shows “Live Video Interrupted”

We have successfully created a Stream File in Streaming Engine on a Linux box on our campus to ingest a stream from an AXIS P1377-LE. Incoming Streams shows that this stream is Active. The Stream Target to Facebook is also Active.

When we stream to Facebook Live from Wirecast on a MacBook, we never get the “Live Video Interrupted” message.

We currently only push RTMP to Facebook. If you look at the [install-dir]/conf/live/PushPublishMap entry, you’ll see rtmp-facebook as the profile type.

How the flow goes:
Your rtsp stream will be attached to a silent MP4 -> then given a new stream name -> Wowza Streaming Engine will transmux the stream to RTMP -> The Facebook Stream target will push Secure RTMP to Facebook

It could be the different frame rate and encoder settings that are set up in the AXIS stream vs. the Wirecast stream. We’d need to take a closer look through a support ticket to run some tests-thank you. Have you also tried disabling “authentication required” in Engine when doing the AXIS stream?

Scroll down to the Source Security section and make sure no authentication and passwords are required.

If still an issue, please submit a ticket.

Also, you do realize that Facebook only takes RTMP right? And they require that it be RTMPS actually now.

Hi again, Rose. I do realize that Facebook only takes RTMPs now.

Glad to hear my ticket will be assigned to an engineer today.

In my ticket, I did attach a .zip archive of /config and /logs.

Where exactly were you suggesting that I manually enter the AXIS camera’s playback url?

Thanks, @video streaming person. I submitted a ticket on Friday. It’s ticket # 354448. I’d be happy to run some tests.

I checked the Source Security Section. No authentication is required and there are no client restrictions.

Ok that’s good. Another tip that worked for people in the past was not copying and pasting the playback url for an AXIS workflow, but actually entering the url in manually which is really odd and a huge inconvenience. It has however fixed the issue for a lot of folks. So sorry that for this problem, it’s impossible to debug in forums since we need full access to your config and logs.

If you send us a ticket, we can get this worked out for you. Thanks Kenny.

I do see your support ticket. I’ll continue to watch it. It’ll be assigned to an engineer today.