Wowza Community

Haivision Makito RTMP

I’m trying to setup Haivision Makito encoder this product is offering rtmp connection to the server. I did the setup successfully it is pushing the stream and it can be viewed in a flash player. The problem is IOS, it plays audio but there is no video (black screen). Using ffmpeg I extracted the stream info, this is the output:

Duration: N/A, start: 0.000000, bitrate: N/A
Stream #0:0: Video: h264 (Main), yuv420p, 720x576 [SAR 16:15 DAR 4:3], 25 fps, 50 tbr, 1k tbn, 50 tbc
Stream #0:1: Audio: aac, 48000 Hz, stereo, fltp

So it appears to be h264 encoded, what can be causing this problem.

Below is ffmpeg output of a working stream in IOS (encoded with FMLE):

Duration: N/A, start: 0.000000, bitrate: 2179 kb/s
Stream #0:0: Video: h264 (High), yuv420p, 960x720, 2048 kb/s, 29.97 tbr, 1k tbn, 2k tbc
Stream #0:1: Audio: aac, 44100 Hz, stereo, fltp, 131 kb/s

Give me some idea where to look for this issue.


Are you sure you have these outputs in the right order? I would expect the one with High Profile to be the problem. H.264 Main profile should work in recent iOS devices, but High is less likely to work. In any case, try Baseline Profile, as that should work in most iOS devices.


I m experiencing the same issues? Was this fixed?


Let’s move this to a support ticket for deeper troubleshooting.

Please send an email to and provide a ZIP file containing your conf/, logs/, transcoder/ and manager/logs folders.

If you are not sure how to get this information please see this tutorial. Please do make sure you provide logs which show Wowza server starting.

In addition to this, please provide a recording (about 5 minutes) of the stream. Here’s how to record a stream if using Wowza Streaming Engine 4 and here’s

the guide to follow if using Wowza Media Server 3.64. or earlier.

If the resulting recording is to large, please share the file (in the support email) with a link to download.



A ticket created has been created to resolve this issue (98007).



No Richard, that is the correct order. I’ve deliberately chosen that stream to show that it plays more complex stream and to ruled out that the profile is the issue.

Also I don’t know if you’ve seen the setup interface of Makito but there is no setting to choose encoding profile like (Baseline, Main nor High).

The problem it seems that is on IOS devices, I can play the stream (same HLS link) on Android device.

What can be causing this to play on web, in Android hls but not in IOS?


I’m experiencing the same issues with both Makito or Barracuda encoders.

Here’s what I’ve recently communicated with HaiVision support:

“…there’s something about your RTMP stream that Wowza doesn’t like. There’s a problem when trying to playout MS Smooth Streams & HLS iOS (chunked stream types). Major buffering issues on Wowza’s own test player. However, when I send a similar source RTMP stream from a Cisco encoder on the same network VTP and VLAN, I don’t have any issues. I’ve also verified this from several different encoders via WowzaStreamingEngine.” Non-chunked stream decoding (RTSP, RTMP, etc) appear to be ok.

Let me know know if you need any additional info, logs, ip captures, etc to help resolve this issue.


The above issue looks to be related to a problem originating from the encoder. I do not see a resolution. It looks like they were able to test successfully with another encoder (Cisco). After testing several encoder options it was determined it would be best to contact HaiVision support directly to see if they had any suggestions. I do not see any reply from the customer regarding what they heard from HaiVision.

I would suggest that if your issue is the same as above that you contact HaiVision support directly to see if they have recorded a solution. If you hear something helpful from them please do reply and I will make record of that information here.

I do see that you have an active Wowza license so do also feel free to submit a support request to us via the support page. Please do include your conf and log folders and your encoder settings.