Wowza Community

MediaCache not working with IIS ARR as HTTP Source....

Hi Wowza forum,

we have just setup a server with the MediaCache add-on.

First some info

“HTTPSource01” is an IIS server with ARR (Application Request Routing) witch is a proxy/cache module for IIS

“HTTPSource01:8080” is an IIS server that has a root in “D:\Media”, this folder holds some 6TB video files in different subfolders

“content/” is the prefix for the MediaCache URL

When pointing the MediaCache at our backend http proxy/cache source, lets call it: (MediaCache Base)

and try to launch a client with this url:

then it fails.

This is what is found in the IIS ARR log:

2012-02-10 09:45:30 HEAD /verylong_path_to/filename.mp4/playlist.m3u8 - 80 - 172.x.y.z - 404 0 2 0

2012-02-10 09:45:30 HEAD /verylong_path_to/filename.mp4/playlist.m3u8 - 80 - 172.x.y.z - 404 0 2 202

2012-02-10 09:45:57 HEAD /verylong_path_to/filename.mp4 - 80 - 172.x.y.z - 404 0 2 0

2012-02-10 09:45:57 HEAD /verylong_path_to/filename.mp4 - 80 - 172.x.y.z - 404 0 2 202

2012-02-10 09:53:08 HEAD /verylong_path_to/filename.mp4 - 80 - 172.x.y.z - 404 0 2 0

2012-02-10 09:53:08 HEAD /verylong_path_to/filename.mp4 - 80 - 172.x.y.z - 404 0 2 202

However if i try to open the direct URL in my browser ( it works fine…

Now we try to change MediaCache basepath to:

and tries to launch a client with this url (the same, as before):

then it works!?

This is log from the IIS:

2012-02-10 10:23:39 HEAD /verylong_path_to/filename.mp4 - 8080 - 172.x.y.z - 200 0 0 124

2012-02-10 10:23:39 GET /verylong_path_to/filename.mp4 - 8080 - 172.x.y.z - 206 0 0 78

2012-02-10 10:23:39 GET /verylong_path_to/filename.mp4 - 8080 - 172.x.y.z - 206 0 0 31

This somehow tells me that MediaCache / Wowza does not like something that it gets from the IIS ARR in the HEAD request it makes…

Any advice would be greatly appreciated

Friendly regards

Stefan B. Christensen


Sorry for delay. I’m not exactly sure why it does not work. I know RTMP streaming does not work through a proxy and evidently (according to your report) MediaCache does not work with a proxy. Can you work-around or with this limit?


If you can send us a public URL to the IIS ARR setup that is not working we can take a look. You can send it to


Yes, start a support ticket as Charlie suggested. Follow the guidelines here:

Try to provide as much detail as possible to narrow down the problem. Provide links to the appropriate stream URLs.


we are using the MediaCache add-on to be able to source via HTTP from our +6TB available videos.

Won’t we be able to source from HTTP with MediaCache if we want to deliver in RTSP, RTMP and Apple HLS?

The IIS ARR is “essentially” the same as SQUID and my understanding is that MediaCache should be able to HTTP source from SQUID, isn’t that the idea with MediaCache or are we using it wrongly?

Our scenario is that we want to be able to source a bunch of files from some backend server(s) that have direct access to the storage. My understanding is that this is the precise purpose of MediaCache?


I can’t send an URL to ISS with ARR, it’s on the backend storage…

This is the setup:

Internet, clients connect from here


Wowza (with MediaCache)


IIS + ARR (port:80), cache files from localhost:8080 onto fast local storage drive E:/Cache

IIS with root in D:/Media (port :8080)


Network Attached Storage mounted as drive D: on server

When Wowza connect to port 80, then the files should be cached by ARR (which it does) and the be server to the Wowza (which it doesn’t), 404 is thrown, but when I access the same URL, that Wowza tries, from my client pc (on the LAN, same network as Wowza) then it works fine…

I can sent you the URL to the Wowza, but I don’t think that would help much?


Problem is now solved. :slight_smile:

We found with the help from the great Wowza support team, that it was an issue inside the HTTP conversation that the MediaCache add-on for Wowza there was an issue.

This could be fixed with making an URL rewrite on the IIS + ARR server, but the Wowza team delivered an updated version of the MediaCache add-on and now it works out-of-the-box :slight_smile:

So Wowza + MediaCache + IIS & ARR works great :wink: