Wowza Community

MediaSecurity AddOn Package (SecureToken, RTMP & RTSP Authentication and more)

The jar file is in the package. In the lib folder of the zip archive.


We do not distribute the source for this module. You can create a class that implements the IAuthenticateUsernamePasswordProvider interface and it will intercept the authentication events. First, install the latest patch:

Then take a look at this forum post. It explains the basics.


Hi all -

The User guide for the Media Security package indicates this URL shows how to setup JW Player, but the link is broken:

I couldn’t find it in a search.

The documentation for version 2.0 says:



But the file inside the “lib” folder is called “”. Is there a different file to look for.

When I try to use secure connection on the server its coming up with these errors:

Missing function: FCPublish

WARN server comment 2010-01-23 00:22:45 - - - - - 149.38 - - - - - - - Missing function: createStream

WARN server comment 2010-01-23 00:22:56 - - - - - 159.633 - - - - - - - Missing function: deleteStream

WARN server comment 2010-01-23 00:22:59 - - - - - 162.57 - - - - - - - Missing function: releaseStream

WARN server comment 2010-01-23 00:22:59 - - - - - 162.57 - - - - - - - Missing function: FCPublish

WARN server comment 2010-01-23 00:22:59 - - - - - 162.571 - - - - - - - Missing function: createStream

Not sure what that means.

Thanks for any help

Hi guys,

I’ve been having problems with the security settings since day one so I’m back to basics. I’m just trying to use ModuleRTMPAuthenticate so nobody else can stream into my server.

I’ve followed every step in the guide and I can still stream from Wirecast without credentials. I’m working with the live application to record my streams to my S3 bucket. Here’s my current conf/live/Application.xml:

			StorageDir path variables
			${com.wowza.wms.AppHome} - Application home directory
			${com.wowza.wms.ConfigHome} - Configuration home directory
			${com.wowza.wms.context.VHost} - Virtual host name
			${com.wowza.wms.context.VHostConfigHome} - Virtual host config directory
			${com.wowza.wms.context.Application} - Application name
			${com.wowza.wms.context.ApplicationInstance} - Application instance name
			<!-- LiveStreamPacketizers (separate with commas): cupertinostreamingpacketizer, smoothstreamingpacketizer, cupertinostreamingrepeater, smoothstreamingrepeater -->
			<!-- Properties defined here will override any properties defined in conf/Streams.xml for any streams types loaded by this application -->
		<!-- HTTPStreamers (separate with commas): cupertinostreaming, smoothstreaming -->
			<!-- RTP/Authentication/[type]Methods defined in Authentication.xml. Default setup includes; none, basic, digest -->
			<!-- RTP/AVSyncMethod. Valid values are: senderreport, systemclock, rtptimecode -->
				<Description>Client Logging</Description>

I’ve tried none, basic and digest for PublishMethod and the video gets streamed/recorded no matter what. What can be the problem?

I have a similar problem if I try to use (in a clean application) the ModuleRequireSecureConnection. I can stream with both RTMP and RTMPE. Is it possible that I have to “turn on” these modules in my Wowza Server somewhere else? Simply adding them to my Application.xml doesn’t seem to affect anything at all.

BTW I did put a new username and password in the publish.password file.

Any thoughts?

Thanks :wink:

Are you connecting using RTMPE? This is required if you have requireSecureConnection set.


It is in the packaged referenced in the first post.


That’s the right jar file for that Module.

The errors indicate the Application.xml is malformed, something is out of place. If you can’t spot it, just start over with a new copy from /conf/Application.xml


A jar file might have any number of Classes inside, the name is not going to indicate what those are.

You don’t need ModuleSecureToken because you already have the ModuleRTMPAuthentication, which includes SecureToken.

Refer to the ModuleRTMPAuthentication section of Security Addon guide.


With requireSecureConnection you need to use rtmpe protocol in the player.



Right, that’s still just malformed Application.xml

If you can’t see the problem, it’s best to get a new copy and start over.


If you use a new copy and remake your changes it will fix it. Try it.


I put it in an xml validator:

And I think the problem might be your secret token, the ampersand maybe. Take out the secret token completely, see if that fixes it, then try a new one token, don’t use ampersand.


When I try it in LiveVideoStreaming example player, the message is “Application rejected connection”. Check the doConnect token.

Try getting it to work in the example player first.


You have the requireSecureConnection Property set to “true”, so you have to use a secure protocol like rtmpe (or rtmps or rtmpte).


This working for me on the example player. SecureToken is still not setup, or SecureURLParams connect. (SecureToken is better, use that.)

You can add SecureToken to the example player. Look for the NetConnection.Connect.Success notification and add this

if ( == "NetConnection.Connect.Success")
				[B]if ( != undefined) //<--- SecureToken change here - respond with decoded secureToken
					var secureResult:Object = new Object();
					secureResult.onResult = function(isSuccessful:Boolean):void
						trace("secureTokenResponse: "+isSuccessful);
					}"secureTokenResponse", new Responder(secureResult.onResult), TEA.decrypt(, "sharedSecret"));		


Also, copy examples/LiveVideoStreaming/clientFlex/src/com to examples/LiveVideoStreaming/client and add import to Actionscript:

import com.meychi.ascrypt.TEA;


You recompiled in Flash CS3 or CS4? Were there errors when you did so? Did you debug in Flash CS3? Sounds like there is an error in the Actionscript.


Does the player come up when you debug?


I am asking if the player appears in Flash CS3 or CS4 when you you select Debug > Debug Movie from the menu.