Wowza Community

Problems with Beamr Transcoding WSE 4.8.14+9

We have Problems with the new Transcoder on the newest WSE. After testing with WSE 4.8.11+5 and 4.8.12+1, we would update all of our Transcoding-Servers to 4.8.14+9. But the latest WSE with Beamr produces choppy Transcodings. Both previous Versions with Beamr runs fine.

We receive Streams via RTMP from Vmix (FFMPEG) in Resolution 1280x720 / 50p at 5Mbit Bandwidth. Our Machines make 2 Renderings from the Source Stream. 480p (2-2,5Mbit) and 360p (1Mbit). Framerate for both Renderings will be halved with SkipFrameCount 1 in the transcode.xml. Then we send the Source and the Renderings via HLS Push from Wowza (Stream-Targets) to the Akamai Network. The Machines do NOT deliver Streams to the End-Users.

Our Servers are Dual Xeon E5-2630v4 (20 Core / 40 Threads @2,2Ghz) or Single AMD Epyc 7302P (16 Core /32 Threads @3,0Ghz) with 64-128GB RAM and 1Gbit Network Connection. Operating System is Windows Server 2012 / 2016 / 2019. Problem is the same on each Machine if we update to 4.8.14+9. With prevoius WSE Versions, we had never this Problem. The Machines run since 2-3 Years without Problems with our Wowza Setup. The Setup itself is nothing special and uses the Default Settings of WSE in a wide Range.

Here is a Test-Page, there you can see the Problem. Wait for the running Icehockey-Game, if not in Picture. There you can see best what i mean ->

Can anyone verify this and has Suggestions for me?

Hello @Marcel_Linke, this is a known issue in 4.8.14 and I apologize for the inconvenience. What you can do is try to try setting B-frames to 0 for your transcoder.

We had changed this default from 0 to 3 and it seems to be causing some issues for some folks.

Here’s how you change the B-frame settings:

It looks like that beamr4.bframe = 0 in Transcoder-Template solves the Problem for us. Many thanks for the Information @Wowza Staff !