Wowza Community

RTSP Input

I’ve gone through the various tutorials for my issue, but not been able to resolve. My scenario:

A client (I don’t own their infrastructure) is outputting from a MediaPointe DMR to an RTSP URL. I can open this URL in QT and VLC without problem.

I need to bring that stream into an environment that I can share to users on my website.

I’ve tried



and, using VLC to transcode:

This is the error that I’m experiencing:

Unsupported packet type: STAP-B

Unsupported packet type: MTAP-16

Unsupported packet type: FU-B

Unsupported packet type: MTAP-24

Any ideas?

When you open the stream in VLC, check that its codecs are supported by Wowza. In VLC do Tools->Codec Information.

It is probably mpeg-4 part 2, which is not support.

mpeg-4 part 10 (h.264) is required.

You can transcode:


It would be better to transcode on another machine, but can work on same.

If you’d prefer to use a commercial solution for this work, then I’d suggest you look at technology from companies including Harmonic, AllegroDVT, Ripcode (now part of RGB Networks), and MCommsTV. (jw)


You could also use ffmpeg in the cloud, or also check out Hyperstream from Kulabyte - it’s about to be released, and it works very nicely.

Wowza 3 has a transcoding add-on.

The Video Codec is MPEG-4 Video. The Audio Code is MPEG AAC Audio. I think these are supported.

That worked! Can this be done with a robust server transcoding process? Ultimately I want to use the EC2 version for my users. Should I run VLC on the same EC2 server? or use a 3rd party transcoder?

Thanks for the help and recommendation.