Wowza Community

Setup WebRTC group call with Wowza Stream Engine on localhost

Hi, is it possible to use WOWZA WebRTC on Locahost. pls help me. Thanks

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

I want to run it on a local PC

WebRTC on WSE requires an SSL certificate and if I remember correctly; self-signed certs won’t work. So the least you need to do is get a cert and a domain name that you assign to Apart from that it shouldn’t be a problem to run it locally, e.g. for test purposes.

Another option is to launch a cloud machine anywhere; e.g. with AWS. With AWS you only pay for the time that you actually have the instance running, so the costs can be really low, like a few $ per month.

1 Like

Hi, but according to wowza site it seems self-signed SSL is possible: could you clarify this pls. Thanks

A self-signed cert is possible for testing with HTTPS or RTMPS but not for WebRTC. But that’s only AFAIK as it’s been a while since I checked that. We do all our testing on VMs in our cloud lab …

alright… im getting a genuine SSL from a CA. so but I was wondering if my WSE in on my local pc, to run WebRTC on local machine, does the SSL should be installed on https://localhost:8088 or https://localhost:443 or jujst https://localhost?.

Karel is correct that we didn’t allow for self-signed certs with webrtc for a long time and to be honest even though we do now, it’s quite complicated and so much easier to use the StreamLock cert for free from Wowza.

However, if you really want to use a self-signed cert, keep this in mind:

Also worth considering, but again it is possible to do with Engine and WebRTC, just a lot more involved:

Note: Self-signed certificates are considered untrustworthy by most browsers. We recommend using a signed certificate from Wowza or another trusted certificate authority.

Also one such existing post on this topic that might help you.

Hi, could you confirm if the method on this link may work with WOWZA WebRTC on local pc?

as per that page it reads as can access the local pc as https://client1.local

Thank you.

Never tried that. IMO it’s simply not worth the time if you can get an SSL cert for less than $4 a year. Or get a Letsencrypt cert and use it in Wowza.

Yes, I also prefer SSL cert. but it seems any SSL wont work with local PC. thats the reason Im looking it to. so as long as you could confirm if I access to my wowza on local pc as: https:// would the WebRTC wil work or not. im assuming the WebRTC only requires https://. Thanks

If you are just planning to test WebRTC things from localhost it might work. While testing or developing you can probably use


and the getUserMedia api call (for camera and mic permissions) will succeed similar to how it does with a proper ssl enabled domain. I haven’t tried with wowza but with similar media server it does work.

If you are looking to do something more than just that then of course you need a proper ssl.

Hi Karel Boek. could you confirm if a self-signed SSL method below may work to use WebRTC on WSE installed on a local pc?

im wonder if I can assign self-signed SSL to IP

Thank you.