Wowza Community

Stream file works with rtsp source, but not with rtmp source

hi, i have a live streaming application using stream files. stream file with source rtsp://

works fine. it is served by evostream

but with rtmp source served by nginx rtmp:// wowz://

wowza does not work.

i see the following message in the wowza logs

RTPSessionDescriptionDataProviderBasic.getStreamInfo: SDP file missing: /usr/local/WowzaStreamingEngine/content/rtmp://

in the incoming streams menu, i can see the incoming stream is stuck in status ‘waiting for stream’

note that i can stream the rtmp source fine through vlc.

any idea why wowza can’t connect/restream the source of this stream file, but vlc is working fine, and the rtsp source works fine with wowza? what can i do to fix it?


How the way Wowza Streaming Engine connects to RTSP and RTMP is different. With the RTMP connection, please be certain to choose the MediaCaster type of “liverepeater” and not the “rtp” option.

MediaCaster types correspond to the following stream types:

  • rtp. IP Camera streams (RTSP/RTP streams) and streams from native RTP and MPEG-TS encoders.
  • shoutcast. SHOUTCast/Icecast streams.
  • liverepeater. Streams pulled from another server running Wowza Streaming Engine.
  • applehls (supported in Wowza Streaming Engine and later). Apple HLS streams pulled from a live source.
  • mpegtstcp (supported in Wowza Streaming Engine and later). MPEG-TS streams pulled from a live source over a TCP/IP connection.
  • srt (supported in Wowza Streaming Engine 4.7.2 and later for Linux and Wowza Streaming Engine 4.7.3 and later for Windows). Secure Reliable Transport (SRT)connections.


Mac Hill

Wowza Media Systems

Thank you very much!

It works by choosing the liverepeater type when connecting to the stream.

Awesome to hear! Thanks @Mac Hill for providing the solution.

Hi @Mac Hill / @Rose Power-Wowza Community Manager

As a follow up to this, the live origin application that is restreaming is set to ‘record all incoming streams’. and for rtp sources we were using ‘rtp-record’ stream type, which automatically recorded the streamed contant. But streams using ‘liverepeater’ type are not being recorded.

I notice there’s no ‘liverepeater-record’ type. And I don’t seen anything in the logs relating to why the liverepeater streams are being recorded.

Do you have any suggestions as to why these are not being recorded automatically? I can record them manually through the ‘incoming stream’ dashboard

does the ‘record all inoming streams’ option on an application work for stream file sources?

i see an alternative - - is that required for liverepeater stream types?

Looking into it for you and be right back @Dev Ops.

Yes, that module will work with liverepeater stream types and one of our engineers just tested it to be sure @Dev Ops.

If you still have an issue, feel free to submit a support ticket and we’ll take a closer look.

indeed, that module also works for us with liverepeater.

I am still curious why the default ‘record all incoming streams’ doesn’t work on its own :). However, this module solution is great. Thanks for checking!

You’re welcome! Anytime…