Wowza Community

Stream Target stuck in Waiting

Hello everybody.

I am obviously new to Wowza tial and need some help for push streaming. We want to push stream from one Wowza(source) to another Wowza(target). We are receiving a live source by using Stream files(a file named

which gives us a stream with the same name. We want to push it to another Wowza using Stream Target. We have configured the stream target as follows:

Source Stream Name


Destination Application Name


Destination Application Instance


Destination Host


Destination Port


Destination Stream Name


User Name

-Not Set-


-Not Set-

On the receiver side, we have configured as follows:

We have created a Stream File named “” with Stream URI as"


Then we have connected to with “MediaCaster Type: rtp” and Application instance "


In Wowza target’s Incoming Streams I see
rtmp://@:2235/ Waiting for Stream

And in Wowza source’s Stream Targets I see the target’s status remaining in yellow “Waiting…”.

What have we done wrong? I have tried Stream URI with:



rtmp://[Wowza source’s IP Addr]:2235/

But still the same.

BTW, I have disabled authentication for RTMP.

I really appreciate your help.

I’m having the same issue more than a year later, has anyone figured out how to start it without having a weird connection sequence?

Did you follow the steps in the docs?

What version of Wowza Streaming Engine are you running? Are you running a trial?

@marko barbancic have you seen my reply?

Hi @marko barbancic, the original post does not have the url set up correctly in any of the examples shared, nor do they have the correct ports configured.

I do see you have submitted a ticket on this for an SRT stream target and they will taking a look at your config today since they couldn’t replicate the issue. Thank you for submitting a ticket so you can resolve this after a year and I’ll be sure to track the progress in ticket #340050.

I have followed the tutorial. The version is 4.7.8 and it is a trial key.