Wowza Community

Wowza Streaming Engine Error with CloudFront

I am trying to get Streaming Engine to work nicely with AWS Cloudfront. If I use the IP address based URL given to me in the “Test Playback” It works great. However, when I try to use the Cloudfront endpoint to replace the IP address, I get an error.
When I try to play it back via VideoJS on a webpage I get an error also. The error is:

I have tried to do all the CORS changes on the CloudFront side without any success. I have tried to replicate the settings in Cloudfront from an old AWS account, but that does not appear to work.
Under Origins, I have set it to Get, Head,Options, and checked Cache HTTP Methods OPTIONS.
I have tried both Cache Policy and Legacy cache settings

Any tips on what I could be doing wrong?

Dear Sir/Madam,
Thank you for contacting Wowza via our forum.

If you’re able to successfully play the streams using the IP address but not via CloudFront (and this results in an “Access-Control-Allow-Origin” error), it’s possible that there’s a mismatch between HTTP and HTTPS.

If CloudFront is using (or expecting) HTTPS, then this message can occur if part of the workflow uses HTTP. If you’re unable to resolve this on the CloudFront side, it may be worth trying to configure the Wowza Streaming Engine software to use an SSL certificate. Wowza provides StreamLock SSL certificates for both commercial and trial licenses for free.

Please find an article below on how to install and configure a StreamLock certificate.

Jason Hilton
Senior Technical Support Engineer
WOWZA | The solution you start with, the partner you scale with.

Wowza Video is here! Look at all the new features that will help elevate your business.

Manage your Support cases online
Bookmark our FAQ page
Bookmark our Status page