Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Wirecast -> Wowza -> internet domain/website -> Flowplayer - Help please

  1. #1

    Default Wirecast -> Wowza -> internet domain/website -> Flowplayer - Help please

    Hello everyone,
    I am new to wowza media server and was hoping for some help.

    What I am trying to do is stream live (real-time) from Wirecast to my website hosted by

    I have uploaded the required Flowplayer files to the root directory of my website and written the correct html code into the websites body.html.

    At the moment I have Wirecast successfully sending the rtmp stream to Wowza. The video stream is viewable via Wowza's live stream test application and from Flowplayer encoded into the body.html of my webpage using localhost or my computers own ip address ( using the following code:

    plugins: {
    rtmp: {
    url: 'flowplayer.rtmp-3.2.11.swf',
    netConnectionUrl: 'rtmp://localhost/live' , //this is the rest of the URL excluding the stream name that you set in the encoder
    subscribe:true //subscribe to the stream

    The thing I need help with is how do I go about taking it one step further to have the stream viewable to everyone at my domain address/webpage at using Flowplayer rather than just localhost? Is it even possible?

    Any help would be greatly appreciated. Thanks very much,

  2. #2
    Join Date
    Jun 2012


    From your description I assume that you have Wowza installed on your local machine.
    In order to have your website visitors access the live stream you are publishing, you need to make your Wowza installation accessible by your internet users.
    You have to figure out what is your public IP ( If the computer with the Wowza server installation is located in a local network, accessing the internet through a router, you need to configure your router to forward the TCP/UDP ports, used by Wowza, to the local IP of your Wowza machine. In the Wowza Quick Start Guide you can find a list of ports used by Wowza.
    To verify that your Wowza installation can be accessed from the internet, open a web browser and try to access this URL: http://[YourPublicIP]:1935. Here is a description on How to verify that Wowza is running
    If everything looks fine, in the Flow player files you uploaded to your web site, in the configuration files you need to change "localhost" with [YourPublicIP].

    If you don't have a fixed public IP, and it may change over time, you can use a Dynamic DNS service such as dyndns who will give you a domain name that will route to your dynamic IP. So, then you would use the domain name they give you instead of your external IP.


  3. #3


    Hello Zoran,
    Thank you very much for your quick response.

    I have now set everything as required as per the various instructions you listed however I having a problem with Wowza and port forwarding.

    I have forwarded the required ports in my adsl router as per your instructions. I have tested if port 1935 with and it is reporting as "closed" as well as every other port on my system.
    I then decided to test if I could open any port to my computer so I used utorrent as a base. I set utorrent to port 11621 and opened that port in the router. With utorrent running reports the port as being "open", if I close utorrent the port is reported as "closed".

    Based of the tests with utorrent it looks as though there is some requirement for data to be sending to/through the port for it to open, would you know if this is correct? If so do I need to tell Wowza anyway in any of the configuration to send to port 1935?

    No matter what I do I have been unable to open port 1935 for Wowza. I have verified if Wowza is running via the instructions you posted above, if I use my public IP address the test times out, if I use localhost or the IP address that is assigned to my computer by the dns server on the router it reports back correctly with "Wowza Media Server 3 Trial Edition (Expires: Sep 14, 2012) 3.1.2 build1624".

    Thanks very much,

  4. #4


    I have done a bit more testing...

    I shutdown Wowza server, started utorrent and set it to use port 1935 (with no UPnP port mapping or NAT-PMP port mapping enabled), then reports port 1935 is "open". I shutdown utorrent and the port is reported as "closed". I start Wowza server again and reports port 1935 still as being closed.

    For some reason Wowza is not triggering port 1935 to open. Any ideas?

    Here is the information when Wowza starts:
    **I have changed my internal IP address to

  5. #5
    Join Date
    Jun 2012


    From the console output you've sent I can see that wowza server had a successful bind on port 1935 for your local machine (, but wowza server doesn't have a mechanism to manage the firewall and routing table on your ADSL router.
    You need to connect to your router's administrative panel and configure the NAT table entries, so that all incoming connections to the port numbers used by wowza are being forwarded to the IP of your local machine with the wowza installation (
    Also make sure to open up those ports in your router's firewall also.


  6. #6


    Hello Zoran,
    Thanks again for your reply.

    I have checked the adsl modem settings again and all seems to be correct. I have set up port forwarding to my computers IP ( for all the ports required by Wowza:
    TCP 1935: RTMP (all variants), RTSP, Smooth and Cupertino Streaming
    UDP 6970-9999: RTP UDP Streaming
    TCP 8084-8085: JMX/JConsole Monitoring and Administration
    TCP 8086: HTTP Administration
    TCP 80: RTMPT, Smooth Streaming, Cupertino Streaming
    TCP 443: RTMPS
    TCP 554: RTSP

    I have taken a screenshot of the modems settings:

    So as far as I can see the ports should be open. There are no options in the adsl modem (fritz! box 7390) for NAT table entries as you suggested, the only thing there is an option for is to disable NAT which turns the modems firewall off completely by default.

    The open port for utorrent works fine it's just the ports for Wowza won't open. I am really stumped.

  7. #7
    Join Date
    Jun 2012


    It looks like you have added the port forwarding table correctly.
    In the "To Computer" column, can you change the host name "Velocity-1" with the internal IP of your wowza machine (
    Make sure you have Wowza running on your server -
    I see from your previous post that you are running on Windows OS. Can you check if you have Windows firewall running, and if you do, can you disable it? Maybe we have a blockage over there.
    If no other equipment is blocking those ports, you should be able to connect to your ADSL router public IP on port 1935.
    What is your public IP? I can try and connect from my side.


  8. #8


    "Velocity-1" is permanently assigned to the IP address of in another section of the adsl modem settings:

    Wowza is definitely running on the machine with the IP address of, however I am unsure if I need to make any alterations to any of the xml configuration files to reflect this?

    Windows firewall is 100% off, as is my virus program as well (just in case it is blocking something). I have no other firewall programs on the computer, windows firewall is the only thing.

    I will message you my public IP address if that's ok so I don't get spammed of DDOS attacked

    Thanks again for your time in trying to resolve the issue.

  9. #9


    P.S - I tried to private message you my public IP address but I think you have private messages disabled?

  10. #10
    Join Date
    Jun 2012


    You can open a support ticket by sending an email to
    You can provide all the info in that email.


    PS: You can also check another thread which discussed the same situation you are facing
    Last edited by zoran_u; 08-14-2012 at 05:33 AM.

Page 1 of 2 12 LastLast

Similar Threads

  1. Wowza on domain
    By icyhammer in forum Tutorials Discussion
    Replies: 2
    Last Post: 10-19-2012, 07:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts