Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Could not connect to server: http://localhost:8087 - when trying to login to WSE

  1. #1

    Default Can't connect to server: http://localhost:8087: when trying to login to WSEManager

    Hello,

    I have the user name and password when setup/install correct, but when trying to login to Wowza Streaming Engine Manager I get this error every time: Could not connect to server: http://localhost:8087.
    Last edited by inmidst; 02-13-2014 at 06:17 AM. Reason: spelling correction

  2. #2

    Default

    Two possible issues here are:
    Make sure Wowza is still running when trying to connect to admin panel. Or if you shut down Wowza, re-start then re-launch Wowza Streaming Engine Manager.
    The other possibility is you are using a license for Wowza 3x? You will need a new license for Wowza 4.0

    Salvadore

  3. #3

    Default

    A little more info about the steps you did will make it easier to answer your questions. Just to make sure people dont give possible solutions you might already have tried.

  4. #4

    Default

    I'm having the same problem.

    I ununstalled Wowza 3.x and installed a fresh copy of WME 4. I haven't configured anything.

    Upon startup, WME fails to load. The Manager does load. The following error is seen in the Event Viewer:

    Service WowzaStreamingEngineManager400 received unsupported INTERROGATE control, which will not be handled.

    Any ideas?

  5. #5

    Default

    Quote Originally Posted by inmidst View Post
    Hello,

    I have the user name and password when setup/install correct, but when trying to login to Wowza Streaming Engine Manager I get this error every time: Could not connect to server: http://localhost:8087.
    You haven't mentioned your OS. Wowza SE 4.0.0 fails to start on Windows 32 bit after setup completes. Please see my post. This could also be the case if JRE is not the "server" version. Run the \bin\startup.bat file manually to see what error message shows. If that starts up the server fine, check if the service is getting started or not.

    Sincerely,
    Inderjeet

  6. #6
    Join Date
    Jul 2012
    Posts
    302

    Default

    Hello,

    Thank you for the feedback on these issues. Please let me offer some suggestions:

    I have the user name and password when setup/install correct, but when trying to login to Wowza Streaming Engine Manager I get this error every time: Could not connect to server: http://localhost:8087.
    This may be the result of connecting to a Wowza instance that is running in a hosted/data center environment. Try adding your IP address to the whitelist settings using these instructions from the Quick Start Guide.

    Upon startup, WME fails to load. The Manager does load. The following error is seen in the Event Viewer:
    Service WowzaStreamingEngineManager400 received unsupported INTERROGATE control, which will not be handled.
    Functionally, Wowza Streaming Engine Manager (WSEM) operates in parallel with Wowza Streaming Engine (WSE). It looks like WSE is starting without the WSEM. Try a specific startup sequence to see if that helps the situation. Please refer to these instructions for specifics on how to (1) start Wowza Streaming Engine and then (2) Wowza Streaming Engine Manager.

    - How to start/stop WSE
    - How to start/stop WSE Manager

    1. Using the instructions from the QuickStart Guide, try manually starting Wowza as a service.
    2. Confirm that Wowza Streaming Engine is running by testing this URL, in a web browser, which should return some version information:

    http://[wowza-ip-address]:1935

    3. Start Wowza Streaming Engine Manager
    4. Access Wowza Stream Manager using this URL and attempt to login:

    http://[wowza-ip-address]:8088

    If these issues persist, please create a support ticket by sending an email to support@wowza.com. Please include a reference to this post and attach the following as a .zip (or other archive):

    [install-dir]/conf
    [install-dir]/logs
    [install-dir]/manager/logs


    We are very excited with this new release and look forward to hearing from you.

    Please keep us posted.

    -Tim

  7. #7

    Default

    I forgot to specify the proxy server in the new install. Thank you for the help and sorry for wasting time.

    Running startup.bat for the command line returned a messaged stating that the license server couldn't be reached. I also performed a packet capture to confirm that the requested was being blocked because a proxy was not specified.

    Thanks again for the help.

  8. #8
    Join Date
    Sep 2011
    Posts
    1,920

    Default

    Hi,
    That's great news, I'm glad it's working for you.

    Thanks for the update.
    Jason

  9. #9
    Join Date
    Feb 2014
    Posts
    1

    Lightbulb

    Quote Originally Posted by tim_d View Post
    Hello,

    Thank you for the feedback on these issues. Please let me offer some suggestions:



    This may be the result of connecting to a Wowza instance that is running in a hosted/data center environment. Try adding your IP address to the whitelist settings using these instructions from the Quick Start Guide.



    Functionally, Wowza Streaming Engine Manager (WSEM) operates in parallel with Wowza Streaming Engine (WSE). It looks like WSE is starting without the WSEM. Try a specific startup sequence to see if that helps the situation. Please refer to these instructions for specifics on how to (1) start Wowza Streaming Engine and then (2) Wowza Streaming Engine Manager.

    - How to start/stop WSE
    - How to start/stop WSE Manager

    1. Using the instructions from the QuickStart Guide, try manually starting Wowza as a service.
    2. Confirm that Wowza Streaming Engine is running by testing this URL, in a web browser, which should return some version information:

    http://[wowza-ip-address]:1935

    3. Start Wowza Streaming Engine Manager
    4. Access Wowza Stream Manager using this URL and attempt to login:

    http://[wowza-ip-address]:8088

    If these issues persist, please create a support ticket by sending an email to support@wowza.com. Please include a reference to this post and attach the following as a .zip (or other archive):

    [install-dir]/conf
    [install-dir]/logs
    [install-dir]/manager/logs


    We are very excited with this new release and look forward to hearing from you.

    Please keep us posted.

    -Tim
    -----------------------------------------------------------------------------------------------------------------


    Hi Tim,

    i've just installed a fresh new installation of wowza on FreeBSD 10.0-RELEASE.
    had to edit some shell script, but after that the installation when flawless...;-)

    Im now connecting with a pc to this Wowza server and for the first time i got a welcome wizard.
    after this wizard i had to login with the admin user i make during the installation.
    When i try to login i got this error message.
    WARN rest REST API: Authentication: Could not access server:http://localhost:8087:
    The ip of the server is 10.65.18.40
    As well as the Manager as the Engine are running.

    Netstat show's:

    tcp4 0 0 amcmnv01.chellom.8088 amcmws480.chello.49226 TIME_WAIT
    tcp4 0 0 amcmnv01.chellom.8088 amcmws480.chello.49225 TIME_WAIT
    tcp4 0 0 amcmnv01.chellom.8088 amcmws480.chello.49223 TIME_WAIT
    tcp4 0 0 amcmnv01.chellom.8088 amcmws480.chello.49222 TIME_WAIT
    tcp46 0 0 *.8009 *.* LISTEN
    tcp46 0 0 *.8088 *.* LISTEN
    tcp4 0 0 *.8086 *.* LISTEN
    tcp4 0 0 *.1935 *.* LISTEN
    tcp4 0 0 *.8083 *.* LISTEN
    tcp4 0 0 *.8087 *.* LISTEN

    Log file show's:

    INFO server comment - Server runmode: standalone
    INFO server comment - Server native.platform: linux
    INFO server comment - Server threads[h/t]: 360/240
    INFO server comment - RESTServer: Bind attempt ([any]:8087)
    INFO server comment - RESTServer: Bind successful ([any]:8087)
    INFO server comment - RESTServer: Using configs from:/usr/local/WowzaStreamingEngine/
    INFO server comment - RESTServer: SSL:No
    INFO server comment - RESTServer: BasicAuth:No
    INFO server comment - RESTServer: Digest:Yes
    INFO server comment - RESTServer: XML Viewer:No
    INFO server comment - Wowza REST API started
    INFO server comment - CMDInterface now listening: [any]:8083
    INFO server comment - MediaCache[MediaCache]: Thread pool size: [writer/readahead]:12/6
    INFO server comment - MediaCache[MediaCache]: MAX Pending size: [writer/readahead]:500M/25M
    INFO server comment - MediaCache[MediaCache]: Add store: path:/usr/local/WowzaStreamingEngine/mediacache maxSize:10737418240
    INFO server comment - MediaCache[MediaCache]: Add source[dvrorigin]: prefix:dvrorigin/ basePath:http://
    INFO server comment - MediaCache[MediaCache]: Flushing cache: start
    INFO server comment - MediaCache[MediaCache]: Flushing cache: done
    INFO server comment - MediaCache[MediaCache]: Start MediaCache GC
    INFO server comment - MediaCache[MediaCache]: Started
    INFO vhost vhost-start _defaultVHost_ -
    INFO server comment - _defaultVHost_ threads[h/t]:0/0 home:/usr/local/WowzaStreamingEngine
    INFO vhost comment _defaultVHost_ Bind attempt ([any]:1935:12)
    INFO vhost comment _defaultVHost_ Bind successful ([any]:1935)
    INFO vhost comment _defaultVHost_ Bind attempt ([any]:8086:4)
    INFO vhost comment _defaultVHost_ Bind successful ([any]:8086)
    INFO server comment - Server.startShutdownHook: Start server shutdown hook
    INFO server comment - StatsManager:startManager() Enabled=true
    INFO server comment - Wowza Streaming Engine is started!




    Java error:
    2014-02-19 11:06:38,778 [RequestHandlerThread[15]] ERROR net.winstone.core.listener.RequestHandlerThread - Socket read timed out - exiting request handler thread
    java.net.SocketTimeoutException: Read timed out
    at java.net.SocketInputStream.socketRead0(Native Method)
    at java.net.SocketInputStream.read(SocketInputStream.java:146)
    at java.net.SocketInputStream.read(SocketInputStream.java:199)
    at net.winstone.core.WinstoneInputStream.read(WinstoneInputStream.java:56)
    at javax.servlet.ServletInputStream.readLine(ServletInputStream.java:104)
    at net.winstone.core.WinstoneInputStream.readLine(WinstoneInputStream.java:121)
    at net.winstone.core.listener.HttpListener.parseURI(HttpListener.java:240)
    at net.winstone.core.listener.RequestHandlerThread.run(RequestHandlerThread.java:91)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
    at java.util.concurrent.FutureTask.run(FutureTask.java:166)
    at net.winstone.util.BoundedExecutorService$1.run(BoundedExecutorService.java:81)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:701)
    WARN rest REST API: Authentication: Could not access server:http://localhost:8087:

    Any idea ....

  10. #10
    Join Date
    Feb 2014
    Posts
    1

    Default

    Hi Tim,

    I have the same issue that rmahangoe has. In my case FreeBSD9.0-RELEASE. Everything looks fine but the manager can't authenticate.
    If I manually connect to port 8087 via browser, I'm requested user and password and after submission I see the standard one-line-info for the server.
    On port 8088 I get the manager's interface that leads me to the login panel but then it fails authentication as per rmahangoe's post.
    The manager's logs show the failed attempt. The server log shows absolutely nothing as if the request had never even reached the server (as in a wrong URL).

    Any help would be great,
    rdm

Page 1 of 3 123 LastLast

Similar Threads

  1. Can't connect to WSE Manager on port 8088
    By kanujbhatnagar in forum General Forum
    Replies: 1
    Last Post: 07-25-2014, 04:00 AM
  2. Replies: 3
    Last Post: 05-01-2014, 08:44 AM
  3. Replies: 1
    Last Post: 03-07-2014, 07:04 PM
  4. WSE Manager - Login security
    By lgbmdev in forum General Forum
    Replies: 1
    Last Post: 03-03-2014, 01:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •