Results 1 to 4 of 4

Thread: Injected cuepoints into live stream not persisting on recorded file

  1. #1

    Default Injected cuepoints into live stream not persisting on recorded file

    I inject cuepoints into a live stream using a server-side module that is triggered from the client-side. I then capture the injected cuepoints from the recorded video file using custom code. On 3.6.4, this was not an issue, but it is now an issue for Wowza 4.x. On Wowza 4.x, it seems that the data is being sent into the data packet of the live stream, but not being persisted into the video recording.

    I am recording to an MP4 container.

    I follow this as the baseline example: http://www.wowza.com/forums/content....ts-or-metadata

    Please assist. Thanks.

  2. #2
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    Do ensure that you have 'Record Data" enabled for the recording method that you are using.
    If recording through the Manager then use this.

    Daren

  3. #3

    Default

    That was it. I enabled Record Data from the admin UI for my app and it's working again. Thanks.

  4. #4

    Default

    Thanks for the update and the fix.

    Regards,

    salvadore

Similar Threads

  1. Stream video file with cuepoints as live and then switch to live stream
    By notreemedia in forum Live Streaming and Encoder Discussion
    Replies: 4
    Last Post: 02-28-2012, 08:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •